X and Fluxbox :: Reconfiguring X on Boot

I have a Toshiba 3110ct that I am trying to install DSL on. It does not have a CDROM drive, so I found a tip on the net that said to put it's hard drive into another machine (in my case a Thinkpad R51) and install Linux (in his case Mepis) on it, then transfer the drive back into the Toshiba and boot up. The tip author says he had to first rename /etc/X11/xorg.conf while the HD was in his build machine so that X would reconfigure on boot. This is to be done before transferring it into the Toshiba. Here's the link for the tip -

In the case of DSL, do I just need to rename .xserverrc ? Or do I need to bother at all? I'd like to get this right as DSL is installed and ready to go in the R51 (hard drive install, not frugal) and it is not trivial to install the HD in the Toshiba. Any tips would be appreciated. If I can boot to a root command prompt, what would be the command to reconfigure X for DSL.? Is it sudo xserver.sh ?

As you can see I did just enough research to be dangerous :). Thanks in advance from a long time Linux user but a newbie to DSL.

Well, I got impatient and tried it anyway. The Toshiba boots up to Entering run level 5, then just hangs on 'If you want to change resolution, run 'xsetup.sh', with a blinking cursor. Any ideas on how I can configure X at this point?

Edit: I was able to boot into run level 2 and I ran sudo xsetup.sh. I went through the screens and rebooted. Same issue, hangs in the same spot.

Edit2: I reinstalled DSL one more time, this one was a frugal install. Exact same issue. Can anyone give me some hints on how I can install xorg? I am thinking this old Trident Cyber 9525 Video  chipset is not supported in DSL out of the box. Keep in mind again, no CDROM. This laptop does have a USB port and I do have USB thumb drives. Also, I do not have a network connection yet.

How do I install XFree86.dsl from run level 2?


It looks like the Trident Cyber 9525 is supported -


Please help me get DSL running ... I think I am close.

Do you need the full Xfree setup? Have a look at:

I should think you will find some way to get X to boot from the above page.

The dsl 3 cheat code gets me into run level 3 with no problem. When I issue the command 'Xvesa -listmodes' I get the blinking cursor, and there it stays.
Next Page...
original here.