Net :: Trying to addLinNeighborhood to extension

I'm trying to add LinNeighborhood to a Samba-3 extension I'm working on, but I seem to have a problem with permissions.

It's myunderstanding that the permissions on the files in /opt/app should be root.root. When I run LinNeighborhood, the window comes up with the machines on the network, but when I try to mount a share I get the following error:

"smbmnt must be installed suid root for direct user mounts (1001, 1001) smbmnt failed: 1"

The permissions on LinNeighborhood are root.root so I don't understand why I get this error. In fact, I get the same error if I move the samba.dsl extension to /opt as well...

Any ideas? I'm launching LinNeighborhood as user dsl.

What's the permission on the executable? (paste from `ls -l`)

suid or setuid means to set the permission bit on a file to have it executed as the owner of the file... in this case the owner has to be root.
Try comparing the permissions on the file before and after you run `chmod u+s <your file>`

Suid means the s flag, it would look like this if it was set: rwsr-xr-x linneighborhood
just chmod u+s it..

Hats, this time you beat me :P
Code Sample
$ sudo chmod u+s /opt/samba-3/bin/smbmnt
$ sudo chmod u+s /opt/samba-3/bin/smbumount

Seems to have done the trick.

It didn't like:
Code Sample
$ sudo chmod u+s /opt/samba-3/bin/LinNeighborhood
$ LinNeighborhood

Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

Refusing to initialize GTK+.
So I took that off again with emelFM (now I know what that set uid button does).

'Learning something every day - is that in the dsl book?  :)

Next Page...
original here.