System :: Problem installing jre1_5_0.tar.gz

HI Everyone,

I have been using DSL off and on for a few years, mostly as a place to learn and fool around with linux.

I know java works... I just cant get it to.

I have tried on the DSL 3.3 version that came with the book and have tried on the latest 4.4 version i have downloaded.

when I load the java it appears to install ok, but firefox does not recognize that java is installed and keeps prompting me to download and install manually.

Any hep would be appreciated.


Any help here would be swell, even if it is to tell me that I am an idiot and there is a simple solution.


you install with mydslapp or with tar blabla.gz?

try with mydslapp...and feedback...

be patient the gurus are with the new kernel...

beers to ragnar

Test Java. After installing, in a terminal, try "java -V"

What does it say?

I use the jre-1_5_0.uci extension from the repo without problems.

Newer versions of java will  not work with the old firefox on earlier dsl versions (I tried to get java-1-6 working, until firefox-1 docs revealed it will not work with that version).  Also, I have a feeling newer java will not work with firefox-2.0 (Bon Echo) either but I'm not sure.

Most apps that use java will look in /opt for it, but it is not in PATH by default I don't think.

So to see the java version, invoke with the full path:

Code Sample
/opt/jre1_5_0/bin/java -version

I don't think there is any such option as "-V".

Next Page...
original here.