Window Mangers :: need help with persistent icewm wallpaper

I can't seem to get my wallpaper to be persistent in icewm.  I can change it with Desktop-->Wallpaper-->item from list.

I am sure it is a quick fix, but I just don't know what to edit.


Are you using wallpaper.lua and selecting "install" after you've selected whatever wallpaper?
I just selected the wallpaper that was already there from the liquidglass theme that loads.  Can I use one that already is there or do I have to "Install" one that isn't there in order for it to "stay" on reboot?
The wallpaper application persists only for fluxbox and jwm.
If you want a background to remain for icewm or any other window manager, you have to set it from .xinitrc or from the window manager's startup script if it has one. Some window managers set the background after starting, overriding what you may have done in .xinitrc.

In the case of IceWM specifically, each theme has its own background, so you may need to copy your chosen theme to /home/dsl/.icewm/themes and modify it.

If I wanted to add/change a wallpaper in icewm but keep the rest of the theme, say using "liquidglass.jpg,"  what should the line look like and where should I put it?  I can figure out the path part, as I know where the file "liquidglass.jpg" resides but I want to make sure the syntax is correct.  I could also just copy and rename to "liquidglass.jpg" to the name of the file my icewm theme calls for.  Would this work.  I don't want to do something and not have my window manager start:-)

Everyone replying seems very knowledgeable, so maybe you can also help me with this kind of related persistency thing:

I added exec xscreensaver $ to one of the files (I can't remember and I am not at home using my computer right now, but alphabetically, it is the last ".x" configuration file in my home/dsl directory, the one modified for XFree86) and the xscreensaver daemon still does not start on load.  I found this suggestion in a different forum.

The reason I am needing to try this: after getting xfree86 to work (using it because the "out of box" configuration tools could not run my monitor at 1280x1024), my screen would not blank automatically like it did with the out of box configuration of my screen/monitor.  If anyone knows how to get this to happen again using xfree86 and by NOT using xscreensaver, that would be great. I don't really need screensavers, and would rather my monitor just shut off.

I have added a line in my xfree86config-4 file under the monitor section option "DPMS", but this only allowed xcreensaver, once opened and the daemon started from there, to shut off the monitor after my set time.

I have an athalon xp 2.1 GHz with 2 MB of ram, so I run other os's with decent speed.  I just like DSL... it is kind of like having an odd child:-)  Lots of work, but seems strangely rewarding.

Next Page...
original here.