Release Candidates :: DSL v4.1RC3

The third release candidate for DSL v4.1 is now available.

Cumlative Change Log for v4.1:

* New notepad (editor.lua)
* Updated pciutils to 2.2.9
* Added pop-ups to jwm tray
* Added *.siag to supported dfm extensions (.dfmext)
* Restored to LHC 4-in-a-row.
* Fixed bug in exitcheck (/opt/.filetool.lst)
* Fixed reported bug in cpanel when booted legacy
* Fixed reported bug mountci (permissions and menus)
* Fixed reported bug in netcardconf (/opt/.filetool.lst)

* Completed support for alternate window managers.
* Removed background/wallpaper control from dfm and .xinitrc
* Created /opt/.backgrounds, use xsri in window file include
* Updated wallpaper.lua to use new structure
* Updated "Getting Started" with Esc and Backspace key definitions for dfm

* New boot option user=name
* New boot option settime settime=its_server_name (must have boot time net access) use with tz=XX/Yyyyy for accurate local time.
* New mini-icons in jwm mydsl menu when available.
* New iconView.lua - View & Edit xpm icons.
* Updated torsmo to v0.18 - now supports noswap
* Updated .dfminfo now a plain text file.
* Updated processing order of extensions with .tar.gz now last to better support myconf.tar.gz
* Root menu solely under user control - defaults to selected window manager menu.
* Added 'toram' to frugal installed grub checkfs menu item.
* Updated several murgaLua programs to reflect the dropped fl_ask GUI widget.
* Dropped SWM - Small Window Manager.
* Fixed link error.
* Better support for alternate window managers. - see /opt/.mydsl_menu/ and ~/.{wm}.inc
* Streamlined MyDSL download procedure - dropped use of sudo and download location prompt.
* Dropped unsued emelfm wrapper.

Many, many programs, files, and their locations have changed to support the new user=name option and the new window manager support.
Most noteably .filetool.lst and .xfiletool.lst are now under /opt.

Files likely in your backup that changed since 4.1RC2


Hey Robert,


the file is moved to /opt .... BIGGE problemo ....

I wanted to upgrade from 0.7 to 4.0 on my harddrive install and i hit this problem:

root : hda1
/opt : hdb1 ( I run a webserver under opt , xampp )

normally I put 1 line in to mount /opt on hdb1 , but that's impossible now. Can you please move again to /usr/bin  ?Or has it other reasons ?

In this way we can upgrade the harddisk version eassier... without everytime doing the job of installing again our appz in /opt ...
/etc/fstab is at every boot overwritten by knoppix ( which is good because I use softraid. also ...
Do you have another solution ?

Kind regards and keep up the good work.

Hi Robert!

It seems as DSL at boottime looks for myDSL apps and myDSL optional apps two times and the result is duplicated in the menu. I discovered this on dsl-4.1RC3-embedded. Hope it's of any use. By the way what rootCommand is necessary to make a fluxbox style also change the background? In RC2 xsri worked well but not in RC3.

Thanks for all and have fun,

Quote (dukkieduk @ Nov. 26 2007,04:05)
Hey Robert,


the file is moved to /opt .... BIGGE problemo .... has been in /opt for a long time (e.g., in version 3.x )
Next Page...
original here.