DSL-N :: usb managed by hotplug, now what?

Don't you love catchy topic titles?

Anyway, I started an old thread while using dsl-4 which I was testing.  Basically we have some serial devices which are talking to an ebox.  When I plugged them in via a usb converted (as there was no serial) I got a few errors which were kernel related (the old 2.4).

I moved up to dsl-n and saw better usb support as the usb mouse worked, but I am not sure about the managed by hotplug statement.  When I plug in the device I get no output at all, no errors or anything.  I also tried putting in a simply usb flash card reader with a card in and again no output in /messages at all.

I see there is a hotplug app (/sbin/hotplug) and some config stuff, but if anyone has suggestions, help on getting USB support I would appreciate it.

: lr :

Moved up? To something that's still at RC4 and hasn't had active development in some time? Interesting definition of moving up. Which version of DSL-N? There was a problem with USB in RC3, iirc.

USB mice *work* in DSL. Run xsetup. That's the first option it gives you after choosing xvesa or framebuffer. I've never had a problem with any USB pointing device (mouse, trackball, etc.) with 2.4 kernels.

If you need to check to see what's mounted, what's inserted but not mounted, etc., there are several options.

To check what's mounted:
cat /etc/mtab

To check if a USB device is inserted and recognized:

To check if hotplug has set mount points in /mnt
ls /mnt/sd*

(You're looking for sda1, sda2; sdb1; sdc1; etc., depending on partitions on each device and how many media devices you insert.)

Thanks, just figured out it was the usbserial module causing an error, so a;
modprobe pl2303
modprobe usbserial
did the trick.

I am just stumbling on gcc now.  DSL4 you simply clicked on system, gcc1 and installed it.  I have dsl-n (version4) but when I click mydsl/system I only show 3 pkgs;

dsl-n is based on gtk2 libs and does not have gtk1.
Only those three extensions were created for dsl-n.
Perhaps some DSL extensions will work on dsl-n.
In the old dsl-n fourms some were posted to have known to work.
You wil have to use the web browser approach to fetch from the dsl libaray and tread carefully.

original here.