DSL-N :: Easiest way to start some perl stuff

ok, dsl-4 had at least the basic's, LWP, MakeMaker, etc.

Rather than going crazy with kernel compiling, dsl-n comes with the 2-6 which supports the device I needed.  But, when I start to play with perl, step 1;
perl -MCPAN -e shell gives the (you need CPAN.pm) error.

So after downloading, the attempted;
perl Makefile.pm gives;
"Can't locate ExtUtils/MakeMaker.pm in @INC"

So before I start going depency crazy, and since dsl-4 has a lot already installed, where can I download those .dsl packages?  I didn't see them in the repo's.

The other problem with dsl-n is I don't see how/where to enable apt-get.

Thanks for any help as always.

Save yourself the trouble and get perl-5.8.0 from testing. Includes everything.
Thanks, but not "everything" it seems.  It didn't have LWP/Simple (which installed via a force), but I can't get Device::SerialPort installed.  Through the install I get;
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
After looking throught that, all looks ok until;
configure: exit 77

It looks from looking around that the error seems to be missing g++, but I have the dsl package g++ with libs installed, I don't think I would need the g++ one by itself right?

Thanks again.

A couple of things - dsl-n stands for dsl-not, so several (many?) of the mydsl extensions might not work on dsl-n.

The perl-5.8.0 extension was built to overwrite the stripped version of perl-5.8.0 in dsl - dsl-n used a different stripped version of perl, which might be the cause of your problem.

The gcc mydsl extensions were also written for dsl - I have managed to use them to compile in dsl-n, but they might not work for everything. There is however, a version of gnu-utils for dsl-n

If you look at the dpereciated dsl-n forum (there is a link on the main dsl page), there are a couple of threads about enabling apt-get in dsl-n

Thanks for the update.  I know it's 'not' dsl, but it's supposed to be the big brother (quoting the site).

I have a little ebox, the 1st generation seemed to work, but the 2nd gen's arent with the usb.  Basically these box's are supposed to boot, run 2 perl scripts and collect data from the serial port (there are no serial ports, but a usb-serial adapter worked) to display using a flash file (gflashplayer).

Since the new box's came, dsl-4 is not working (seems usb is not seen), but dsl-n (with the 2.6 kernel) seems to see the usb, but naturally a few other issues.  I got the perl modules working, but gflashplayer spits out an error saying;
error loading shared libraries: libstdc++libc6.2-2.so.3 which seems to come from compat-libstdc.  I found an rpm, converted using alien and when I tried to intstall it got;
dpkg: `install-info' not found on PATH.
dpkg: 1 expected program(s) not found on PATH.
NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.

I am pretty much a fedora guy, so debian, etc. is all new, but I am again stuck between 2 things.  

DSL-N, 2.6 USB support, need the above
DSL-4 - 2.4 no usb (compiling sounded like a nightmare), but gflashplayer works fine.

There is always something . . . .

Next Page...
original here.