HD Install :: cfdisk, don't know designation of the CF-card


Recently I got myself a mITX board (MSI IM-945GSE-A) and a Mini-Box M300LCD case with a CF->PATA convertor in it.

Now it was my intention to do a frugal install of DSL on a 2GB Kingston CF-card (couldn't get one with smaller/lower capacity) but I can't start installing.

The CF-card has to be partitioned first, I know I must use cfdisk for that, but... I don't know the designation (hda/hdb/sda/etc) of the CF-card.

What I do know is that sda1 and sda2 are being used by the USB-flash-drive were DSL will be installed from.

Already tried several of those designations, but cfdisk can't find the CF-card, but it does find the USB-flash-drive.

Any idea what now?

With regards,

Bart Grefte

ps, CF-card is being recognized by the BIOS.

Well, the CF-card was designated as hdc ???

Still couldn't use cfdisk, gave an error, so tried sudo mkfs hdc.
Then tried cfdisk again, which didn't gave an error this time and claimed the CF-card to have no partition on it, so I created one with cfdisk.

Then I did the frugal grub install, which wend okay, I think.

Anyway, when I tried booting from the CF-card, the system gave the "no bootdevice detected" error....

Did I do something wrong?

When you created the partition, did you set the boot flag on it?  This is done in cfdisk, and as far as I know it can be done to an existing non-boot partition that already contains data.
Yeah, I did...

But just in case I started over, but now I can't install DSL ???
Get "Warning: start=63 - this looks like a partition rather than the entire disk. Using fdisk on it is probably meaningless.
[Use the --force option if you really want this]
Sorry, system has not detected a linux partition."

I already took a look in the Official DSL Book, see if I missed something, but that doesn't cover installing DSL from a from USB-stick running DSL...

Next Page...
original here.