Multimedia :: Cannot Configure Sound on Old Laptop

I need to setup sound on my old Laptop {IBM TP 600E 2646 (4BU)}

I tried using sb module using command "modprobe sb" but it gives error "No Such Device"

Also I tried to ALSA but my system hangs every time I try to download it.

Following is the error I found from System Stats

Crystal 4280/46xx + AC97 Audio, version 1.28.32, 11:54:54 Aug 29 2005
cs46xx: Card found at 0x50100000 and 0x50000000, IRQ 11
cs46xx: Thinkpad 600E (unsupported) (1014:1010) at 0x50100000/0x50000000, IRQ 11
cs46xx: AC'97 read problem (ACCTL_DCV), reg = 0x7c returning 0xffff
cs46xx: AC'97 read problem (ACCTL_DCV), reg = 0x7e returning 0xffff
cs46xx: AC'97 write problem, reg = 0x0, val = 0x0
cs46xx: AC'97 read problem (ACCTL_DCV), reg = 0x0 returning 0xffff
ac97_codec: Primary ac97 codec not present"

Please guide me through this. I am Linux newbie just released from Windows Trap.
I did tried to search the DSL forum but coudnt find anyting in search results.
Thanks in adavance.

Did you try some of the suggestions in other threads? (for example, search on cs46xx)

Also I tried to ALSA but my system hangs every time I try to download it.
Did you try to save it to a permanent location and not in /ramdisk ?

Thanks for the tip. Finally got it working after digging in and trying out various parameters. [ALSA & GNU UTIL Not required]

Below are steps that made it chirping [For any other newbie like me].

1) Turn off the "fast boot" option in "Config" section of BIOS setup. [To Reach BIOS: Turn on computer, holding the F1 key until after Thinkpad logo appears to get into the BIOS menu.]

2) Enter the following commands (to load the required sound modules during booting) in {Found in /opt}

modprobe sound
insmod ad1848
insmod uart401
insmod cs4232 io=0x530 irq=5 dma=1 dma2=0

Once again thanks. I am now enjoying DSL.

original here.