Networking :: RTL8187b on 2.4 kernel


I've read quite a bit about the Belkin F5D5070 USB wireless sticks and their problems with linux, but the more I read, the more I got confused...

It seems the rtl8187 kernel module handels this component. It's in the default 2.6.27 kernel.

I have two environments: one a i686 laptop with arch linux running 2.6.27. There, the usb stick works wonderfully with the new 2.6.27 kernel module.

I also have a libretto 100CT, CPU: 166MHz i586, 32MB RAM, which I'd love to be able to run wireless. The Belkin is what I have, so I'd like to go with it.

There I run a 2.4.26 DSL.  With a PCMCIA USB card I expanded the system with USB port - the libretto does not have any; the PCMCIA card seems to work fine:

Code Sample
Bus 003 Device 002: ID 050d:705e Belkin Components

I can't put this configuration to work. Tried downloading drivers and compiling with compile-3.5.5.uci, tried ndiswrapper (ndiswrapper reports
Code Sample
"net8187b             driver installed"

but I can't see the wlan0 (or any other wlan extensions) after
Code Sample
sudo modprobe ndiswrapper

However I got error messages that uhci can't be loaded at boot (or with sudo modprobe uhci):
Code Sample
/lib/modules/2.4.26/kernel/drivers/usb/host/uhci.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
/lib/modules/2.4.26/kernel/drivers/usb/host/uhci.o:insmod /lib/modules/2.4.26/kernel/drivers/usb/host/uhci.o failed
/lib/modules/2.4.26/kernel/drivers/usb/host/uhci.o: insmod uhci failed

Maybe the PCMCIA is not working properly then, even if lsusb clearly shows me the USB wireless stick?

Has anybody got experience with such a configuration?
Thanks, I'd love so much to have my little cutie with wireless :-)

I actually made some progress, by
downloading a different inf file for ndiswrapper,
which now loads wlan0 which I can see with iwconfig.

However, I still can't get any connection.
Whereas with the same stick
Code Sample
iwconfig wlan0 essid MYSID

I can connect with the router from another laptop,
the dsl one doesn't work.
Not sure what I could try next....

Different question. I know I sound lazy and maybe even stupid
for not finding the right info. But I downloaded the source code
for the native 8187b driver which works in 2.6.27.

If I want to compile that driver on DSL with 2.4
1. Will it be possible?
2. How to do it?
I have compiled kernels, so I am not a complete noob, nevertheless I haven't been able to find appropriate info on this on the DSL pages. Sorry.
For the time being, after downloading gcc-1...dsl, make doesn't work, looks like version conflicts.
The driver code has some comment statements that it should work with 2.4, but unfortunately no details.

thanks for any help

This is what I get if I try to compile the driver:
Code Sample
rm -fr *.mod.c *mod.o *.o *.cmd *.mod.* *.ko *.o *~
modules/`uname -r`/build/include -c -o aes.o aes.c
In file included from /lib/modules/2.4.26/build/include/linux/kernel.h:13,
                   from /usr/include/asm/system.h:5,
                   from /lib/modules/2.4.26/build/include/linux/spinlock.h:6,
                   from /lib/modules/2.4.26/build/include/linux/module.h:11,
                   from aes.c:55
/lib/modules/2.4.26/build/include/linux/types.h:21 error: parse error before "dev_t"
In file included from /usr/include/asm/math_emu.h:4,
                   from aes.c:55:
/usr/include/asm/sigcontext.h:79: error: parse error before '*' token
/usr/include/asm/sigcontext.h:82: error: parse error before '}' token

and many more such parse errors.

I have downloaded and installed through mydsl-load local:
Code Sample
gcc1.dsl gnu-utils.dsl kernelsource.dsl

Also tried with downloading whole 2.4.26 kernelsource - nope.
All this trying to follow this thread about compiling drivers in DSL:
compiling drivers
However, seems to be a bit dated thread. In fact,
Code Sample
sudo apt-get install libncurses5-dev patch

doesn't work, I get
Code Sample
E: broken package

with some previous info about unmet dependencies.

From the drivers Readme.txt:
Code Sample
Release Date: 2007-08-22, ver 1.24
RTL8187B Linux driver version 1.24

   --This driver supports RealTek RTL8187/RTL8187B Wireless LAN NIC for
      2.6 kernel:
      //listing of some supported linux distros
     2.4 kernel:
     Redhat 9.2, etc

Which suggests that it should compile on a 2.4.26 kernel....

Nobody can give me a hint??? Please!

original here.