Networking :: Realtek RTL8101E on Acer Aspire One

I cant seem to get this network card to work no matter what I try. It works when running with QEMU under windows, but not from a direct USB boot.

lspci lists it as "Ethernet Controller: Realtek Semiconductor Co., LTD. RTL8101E PCI Express Fast Ethernet Controller".

Nothing found in DMESG.

ifconfig eth0 up = "No such device".

I booted up another computer with the USB card and internet worked fine, so it's not the USB card. I've tried dsl-4.4.10 and dsl-3.4.12

Anyone know what I can do to get this laptop connected to the internet???


You mean it worked on dsl run via QEMU in Windows?


Code Sample
# modprobe r8169

It's not the right module but this

says it can work albeit badly.

You probably need to build the realtek driver from source.

Note that link above gives specific Gentoo and Manrdiva releases this works out of the box on.  Also Google says Kabuntu and Debian Sid, with a recent enough kernel.  Google is your friend.

Quote (WDef @ May 02 2009,22:46)

Yes, it runs in QEMU in Windows.

modprobe r8169 gives a "no such device" error.
modprobe 8390 doesn't give an error, but doesn't work either

I tried "make" with the drivers from realtek, which seem to yield an "error 1" in the process ... lots of messages the scroll too fast for me to read.

I've spent hours on google for several days now, and at this point I'm about ready to just install a windows webserver - productivity is at a standstill here.  :(

Any help appreciated.


original here.