Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
November 25, 2015, 11:46:54 PM

Login with username, password and session length
The new DSL forums are now open.
298242 Posts in 294239 Topics by 256 Members
Latest Member: YasminGart
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  MyDSL Extensions
| |-+  Games
| | |-+  install zandronum or zdoom??????
« previous next »
Pages: [1] Print
Author Topic: install zandronum or zdoom??????  (Read 1116 times)
Posts: 5

View Profile
« on: August 01, 2015, 07:52:43 PM »

Hi guys!!!!
Like the title say
It is posible compile these exelents ports ??
It would be nice run brutal doom in our xbox!!!!!
I try with the src and "make" comandante but sadly
Give me errors
 Any help???
Somebody sucefully compile these?
Thanks foy your time
Full Member
Posts: 183

View Profile
« Reply #1 on: August 02, 2015, 12:58:10 AM »

Looking at this wiki page (http://zdoom.org/wiki/Compile_ZDoom_on_Linux) about compiling Zdoom (I haven't checked zandronum, but presumably it's similar), it looks like compiling in DSL may well be possible, but you'll need to compile some dependencies first.

Most of the dependencies that are not optional will need to be compiled by you because the correct versions are not included with DSL, and they are not in any extensions in the "MyDSL" repository.

gcc 4: no version this late is available pre-compiled for DSL
cmake 2.4: isn't in the MyDSL repository
fmodex 4.26.36: isn't in the MyDSL repository
SDL 2.0.3:   no version this late is available pre-compiled for DSL

Some of these dependencies will probably have dependencies of their own that must then be compiled first if they're not already in DSL or the MyDSL repository at the correct version. It's possible that some dependencies will not be able to compile with the old Linux kernel that DSL uses (version 2.4.31).

Many of these dependencies for dependencies will be covered by packages in the MyDSL repository, "compile-3.3.5.uci" will likely contain many, even though the version of gcc that is included in it is too old to be used to compile Zdoom. This page shows the base packages already included in DSL (http://www.damnsmalllinux.org/packages.html). - Actually, I'm not sure what version of DSL the X-Box port was based on, so that page may not be 100% accurate if you're running X-DSL.

If you find that a dependency can't be installed in DSL due to the Kernel problem, you could try older versions of Zdoom that might be more compatible with the old software base available for DSL.

Finally, in case you don't know, there is the "prboom" version of the Doom engine available for DSL in the MyDSL respository with the file name "doom.dsl". Make sure you get the one for DSL, not DSL-N.

By the way, thanks for reminding me about the Xbox version of DSL, I'll have to try modding the broken Xbox I've got one of these years...
Posts: 5

View Profile
« Reply #2 on: August 02, 2015, 07:53:10 AM »

Thanks really
Ley tell you why i want zdoom por zandronum un muy xbox
Zdoom and zandronum (and lot of doom launchers) are the ones that permit
Run pk3 files,the awesome brutal doom is a pk3 that only run by zdoom and similars.
Xbox have a lot of doom launchers(doom legacy,odamex,doom3)but all of they only soports wad files no one can run pk3 files.
And your welcome
Your xbox is a extraordinary tool and you will note that when you estar to
Install a whole of apps, emuladors, ports and more tools
Dsl 2.2 is the x-dsl based port

And finally.
I try compile the zdoom 1.22 and start
When line go m_fixed.h.......... Stop
Thanks world
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc