Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: HP Deskjet 710C using apsfilter with DSL 1.0, Any helpfull suggestions please ......< Next Oldest | Next Newest >
wolfie Offline

Group: Members
Posts: 1
Joined: April 2005
Posted: April 26 2005,12:50 QUOTE


I need some help. I am trying to get my HP Deskjet 710C printer to work with DSL 1.0,  and would be very grateful if anyone could point me in the right direction + suggest what I should try next.  The printer works fine from Windows.

I have used apsfilter V7.2.5  to configure the printer.  It looks like the only driver for the HP 710C is one of those PPA drivers.  
HP-DeskJet_710C sugestions at linuxprinting

So I have installed + compiled the PNM2PPA filter/driver from   sourceforge.

Now I can get it to generate a test page and write to /tmp, but it won't print it.  :-(  

Maybe someone could suggest another driver that works,  or perhaps trying another configuration software that has worked with the HP Deskjet 710C. I see several mentioned in the DSL forum,  but for different printers : cups, magicfilter,  but it sounds like a lot of legwork to try them all.

Here is what I have tried so far.........its a long explanation.
I get  some clues, when I look around the system,  but I don't see the problem  Can anyone see anything obvious ?     I'll give the configuration later......

When I in apsfilter setup, I select T - to print a test page,   I see the command being formed in the apsfilter window:-
Printing Test page using:
gs -q -dBATCH -dNOPAUSE -dPARANOIDSAFER -dSAFER -r600X -sDEVICE=ppmraw -sPAPERSIZE=a4 -sOutputFile='/tmp/apsfilter585/test_page.aps' setup/ | 'pnm2ppa' -- -v 710

With Verbose error messages switched on I get the message on console :
pnm2ppa: pnm2ppa: Verbose messages
pnm2ppa[process_id]: main(): Could not open PNM input file

Then it takes a half minutes at 99% CPU usage ,  and it seems to be able to generate something, because, the next thing I see is:

Printing test page...
-rw-r--r-- 1 root root  82,845,696  Apr 25 21:10 /tmp/apsfilter585/test_page.aps

But then nothing happens  ....  :-(    so I start to look for problems in the logs......

When I look at /var/log/syslog,  it is zero size, and has no entries,
looking at at /var/log/messages  I see the entry:-

Apr 25 21:09 <hostname> lpr.crit pnm2ppa[process_id]: main(): Could not open PNM input file

The CPU is still slogging away doing something, but nothing is happening on the printer, no data light, no paper movement :-(

so I start looking at processes and ps -ef shows

( process_id+2)  root 440 S  cat /tmp/apsfilter585/test_page.aps
ie. just 2 processes after the Pid above

and the top command shows this as the process taking most of the cpu effort.

Then after a few minutes the cpu effort drops off,  but the cat command is still in the ps listing,  until I kill it.  I left it overnight last night, and still nothing came out.

The suggestions in the PNM2PPA documentation are to check :-
Check for typos in the files.
Check for messages in /var/log/syslog, /var/log/messages, /var/log/lpr.log (dependent on the distribution).
Check /etc/hosts.lpd file. Do you have permissions to use the printer in your system itself?

I am guessing it is some sort of permissions problem,  but it looks like the appsfilter and the cat processes are run as root,  so whats the prob ?
The other weird thing is that I can view all the test pages as DSL user, using the Postscript viewer from the DSL menu's.

I suspect there is more to this, but  can't see it ???  A am I right in my suspicion that syslog logging is disabled ?  or redirected to /dev/null  ?

I have the printer connected to the only parallel port on the PC.  Which I assume must be /dev/lp0
I am in Europe, so I am using A4 sized paper,  I'm not pushing the hardware to its absolute limits,  yet :-)
So the config read like this :-

Print driver ppa/710
Interface Setup parallel /dev/lp0
Paper format A4
Print quality medium
Colour mode full
Resolution dpi 300x300
Default print method auto

The config file  called  /etc/pnm2ppa.conf   has the version set to a value of  710. Version = 0 is commented out, as suggested in the Apsfilter documentation.

Any ideas ?
Thanks W.
Back to top
Profile PM 
Rapidweather Offline

Group: Members
Posts: 375
Joined: Jan. 2004
Posted: May 15 2005,01:58 QUOTE

I noticed that your topic has a lot of reads, but no replies, so here is what I found on these printers on the Yoper Linux forums:
I'm not wanting to sound rude or make light of your printer problem, but there is a chance that the problem is:
A. Not solvable with normal and standard measures.
B. Solvable, but no one who has read your post knows how.
C. Solvable by purchasing a new printer for 59.99 at Walmart.

As you know this printer is the equivalent of a WinPrinter because it uses the Winslows operating system to generate the printing data. That is one reason HP quit making this model and stopped this type of technology all together. This is really an issue that is cause by proprietary code and the lack of support form the vendor because of licensing. I know that I personally spent 2 days trying to find you a method to make it work and returned null. RedHat 7.0 I beleive did have support for this model but it was flacky and the opensource work on this issue stopped when HP quit making this type of technology on thier printers.

The reality of the problem is that you have aborted technology on your hands. Obsolesence! While you may be able to use it with Winslows you won't get it to work with DOS or Linux or any other OS that requires the postscript to be generated at the OS level.

Gee, that guy is kinda rough, isn't he? But, he seems to know something we can use here.
I have noted that the 700 series printers are left out in the DSL printer setup, and wondered about that until I found the above post. I have been trying to get a Deskjet 722C to work in several Linux distros, and all of them so far have not been able to get it to print. All distros seem to see the printer, and list it by name, but that's about it. I do have mine set up in Windows 98, and can, if I find a file I want in Linux, just copy it over to the Windows partition, reboot, and then print it using the Deskjet setup in Windows 98.
I did, however, get one of these printers to work in Mandrake 8 or Redhat 7
once, but I have not kept that installation up, and do remember that the printer quit right in the middle of a small print job, and never worked after that. It was a old printer, taken out of heavy commercial service, and it did work for 3 months before quitting.
Hope this has helped.


Rapidweather Remaster of DSL:
Rapidweather Remaster of Knoppix Linux:
Back to top
Profile PM WEB 
1 replies since April 26 2005,12:50 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: HP Deskjet 710C using apsfilter with DSL 1.0

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code