Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: GCC compilers in the repositry, Incorrect info for gcc1< Next Oldest | Next Newest >
andrewb Offline

Group: Members
Posts: 316
Joined: July 2005
Posted: Aug. 22 2007,23:50 QUOTE

The description of gcc1-with-libs in the unc section of the repositry states:

gcc g++ make for DSL 3.1+

This is a bit misleading as it suggests that this is the compiler required for compiling DSL 3.1+ rather than the gcc 2.95 extension. Can the description please be modified. The info file for gcc1-with-libs also probably needs updated to make it clearer that  the gcc 2.95 complier should be used for compiling the kernel, modules etc, even though the gcc1-with-libs extension also needs to be loaded so all the necessary libraries & utilities (such as 'make') are present.
Back to top
Profile PM 
curaga Offline

Group: Members
Posts: 2163
Joined: Feb. 2007
Posted: Aug. 23 2007,09:46 QUOTE

There is no problem compiling the kernel with gcc 3.3.4 in the extension, 2.95 is only needed for modules for the current kernel.

There's no such thing as life. Those mean little jocks invented it ;)
Windows is not a virus. A virus does something!
Back to top
Profile PM 
1 replies since Aug. 22 2007,23:50 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: GCC compilers in the repositry

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code