Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic
Pages: (3) </ [1] 2 3 >/

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: NTFS Mounting, Help with NTFS Mount< Next Oldest | Next Newest >
gkterry Offline

Group: Members
Posts: 1
Joined: Aug. 2005
Posted: Aug. 03 2005,04:10 QUOTE

I am not a newbie to Linux. In the past I have been the sysadmin for several years of a 4 network that had 4 Linux servers I set up with access to MAC and PC clients. However, that was over 18 months ago and I haven't used Linux since then until lately. DSL Linux has intrigued me but I am having difficulty accessing ntfs partitions. Read only mode is what I want. My ntfs partition should be hda1 and hda2. Does DSL change those partitions to another designation? When I attempt to mount /dev/hda1, I get the following message:

mount: wrong fs type, bad option, bad superblock on /dev/hda1 or too many mounted file systems.

I would appreciate any help clearing out the cobwebs.


Greg Terry
Back to top
Profile PM 
cbagger01 Offline

Group: Members
Posts: 4264
Joined: Oct. 2003
Posted: Aug. 03 2005,04:37 QUOTE

To see what partitions have been autodetected by DSL, open an Xterminal and type:


To do the actual mounting, you should be able to just type something like:

mount /mnt/hda1

Or, as root, you can manually specify the whole process:

sudo su
mkdir /mnt/hda1
mount -t ntfs /dev/hda1 /mnt/hda1

Keep in mind that your NTFS partition might not be in the expected location.  This is especially true for Dells and other PC manufacturers that create a small hidden FAT partition at the beginning of the hard drive that contain the Dell diagnostic utilities.  So in this case, the NTFS partition would actually be at /dev/hda2

If DSL does not autodetect your drives on a newer computer, it may be due to limited support for SATA disk controllers.  Try and go into your BIOS and set your SATA controller for "legacy mode" or "PATA mode" or "OS install mode" and then try booting DSL again.

Or you could download user tronik's unofficial DSL remaster that included linux kernel version 2.4.27 and full SATA support.

Hopefully, some of this information will be helpful.
Back to top
Profile PM 
DeeJay Offline

Group: Members
Posts: 24
Joined: April 2005
Posted: Aug. 03 2005,10:25 QUOTE

Is it relevant that this is posted in the 'Embedded' thread? I think that I am right in saying that QEMU, which hosts the embedded version of DSL on a Windows PC, does not give/allow any access to physical filestore on the host machine, whatever the partition type. Might this be the underlying problem?
Back to top
Profile PM 

Posted: Aug. 03 2005,13:14 QUOTE

I had previously went through all the mount gymnastics. I haven't forgotten that much yet.   :)

there are only 3 drives listed at mount command:

/dev/root on /
/dev/hda on /KNOPPIX
/ramdisk on /ramdisk

I'm beginning to think that DeeJay may be correct and this is a normal occurence with the embedded version DSL. I'll try making a CD of the ISO version later and see if that behaves differently.

Back to top

Posted: Aug. 03 2005,15:00 QUOTE

mount -t ntfs /dev/hda1 /mnt/hda1

works for me. That is my windowsXP drive. I mount it often.

if /dev/hda1 doesn't work try /dev/hdb or maybe even do a

dmesg | grep "hd*" | more
Back to top
11 replies since Aug. 03 2005,04:10 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

Pages: (3) </ [1] 2 3 >/
reply to topic new topic new poll
Quick Reply: NTFS Mounting

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code