Typing non-English characters in DSL


Forum: User Feedback
Topic: Typing non-English characters in DSL
started by: yangmusa

Posted by yangmusa on Sep. 23 2008,17:09
Hi,

I searched the forum, but previous coverage of non-English characters all seemed related to keyboard mapping, which isn't quite what I need. (I search for "non AND English AND characters).

I have an English US keyboard, and mostly work and write in English. But I am Norwegian, and write a lot to friends and family back home, so being able to write the Norwegian characters , and would be helpful.

In Windows, it's easy: alt+0230 = , alt+0248 = and alt+229 = .
On my mac, it's even easier: alt+; = , alt+o = and alt+a = .

So, I don't want to change my keyboard mapping - I just want to be able to enter non-English characters occasionally. I know that in Ted I can do Insert > Symbol and choose the characters from the menu and then copy/paste where needed, but that's really an inconvenient workaround.

Apologies if this has already been covered. I'll try to add the answer to the Wiki....

cheers, Magnus

Posted by curaga on Sep. 23 2008,18:01
Your question does relate to the keyboard mapping. In case those symbols aren't mentioned in the US keymap, there's no way to enter them quickly.

So, check the keymap, and if necessary, modify it.. It's a gzipped text file, and they have to be loaded outside X.

Posted by yangmusa on Sep. 23 2008,18:05
Quote (curaga @ Sep. 23 2008,15:01)
So, check the keymap, and if necessary, modify it..

I'll check the keymap. Where is it stored?

Quote (curaga @ Sep. 23 2008,15:01)
It's a gzipped text file, and they have to be loaded outside X.

I'm not sure I understand the bit about loading it outside X. I cannot open the file in X, or I need to restart X after modifying the file?

thanks, Magnus

Posted by ^thehatsrule^ on Sep. 23 2008,19:05
Or use xmodmap.  Example result from google search that could work: < http://olekvi.livejournal.com/1360.html >
Posted by yangmusa on Sep. 23 2008,20:36
Quote (^thehatsrule^ @ Sep. 23 2008,16:05)
Or use xmodmap. Example result from google search that could work: < http://olekvi.livejournal.com/1360.html >

I made a file called .Xmodmap and inserted the text from the example link. Then I restarted X. No change, still not able to produce , or .

1) Do I need to do anything further to enable xmodmap?
2) I tested this at work using a virtual machine, and it's running Xvesa instead of Xorg. Does this matter? (Wait, does DSL even do full Xorg, or is that just Puppy? I use the two a lot...)

thanks, Magnus

Posted by kuky on Sep. 23 2008,22:02
You add the line to the file   .xinitrc ?

xmodmap /home/dsl/.Xmodmap...

in spanish to add accents

< http://damnsmalllinux.org/cgi-bin....t=18310 >

Posted by ^thehatsrule^ on Sep. 24 2008,04:35
Quote (yangmusa @ Sep. 23 2008,20:36)
2) I tested this at work using a virtual machine, and it's running Xvesa instead of Xorg. Does this matter? (Wait, does DSL even do full Xorg, or is that just Puppy? I use the two a lot...)

My guess is that it can work with either. DSL uses Xvesa by default, but you can load a different X server - see MyDSL.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.