.Xtdesktop taken by root?

Forum: X and Fluxbox
Topic: .Xtdesktop taken by root?
started by: kreon28

Posted by kreon28 on May 22 2007,08:51
During my desktop configuration I've done something what makes me mad.
After reboot on my desktop there are some icons but when I click them one or two times  - nothing happens. (well, I would like to have double-click icons)
I have to right-click on the icon and choose run as superuser - in that moment, the program will run.
To run a program as user I have to click "Icontool" and choose e.g. double-click, then ok.
I must admit that is really annoying.
It looks like my xtdesktop has root privileges.
I did
Code Sample
chown user /.xtdesktop

and even
Code Sample

chmod 777 /.xtdesktop

but nothing changes
Anyone one how can I solve it?
Or maybe at start run some script - which can do that icontool ->doubleclick->ok ?

Posted by lucky13 on May 22 2007,13:15
Open emelfm as root. Click the H (to show hidden files and directories) in the corner of the /home/dsl browser window. Scroll down to .xtdesktop directory. Look inside at the permissions (scroll to the right). Look and see if the files are set for user dsl or for root (especially xtdeskrc). Change anything set for root to dsl.
Posted by mikshaw on May 22 2007,14:51
As I think I've said a dozen times in a dozen places, chown 777 is NEVER a good solution to a problem.
Everything in /home/dsl should be owned by dsl, except in the case of some personal exception of which you are already aware, so "sudo chown -R root.staff /home/dsl/" should fix any ownership problems.  If there is any trouble after that, you have a more serious problem that may or may not be related to xtdesk.

You say your trouble was fixed when you set the double-click?
If so, just backup /home/dsl/.xtdesktop/xtdeskrc after fixing the double-click and enable the backup/restore feature.

Posted by kreon28 on May 22 2007,16:09
Ok, my diagnose was wrong.
I've found out that user also could run a program but I had to do a ...fast three-click (!)
So any chances to make it double-click? (interval is set to 500)

Posted by mikshaw on May 22 2007,22:04
It sounds like you already have double-click enabled.
500 is half a second, which is a rather slow double-click. A single-click would be 0.  I'm not sure why it needs three clicks, but I'd say it might be fixed if you reduce the click interval to something around 200-300.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.