How to get rid of bottom bar?

Forum: X and Fluxbox
Topic: How to get rid of bottom bar?
started by: danielp

Posted by danielp on Nov. 03 2007,21:26
I've just upgraded DSL to 4.0 and see that the window manager is different from 3.4.

I'm using a program called feh to show pictures, and I want to see them on the whole screen. Before (3.4) that worked perfectly, but now the bottom bar stays visible.

How can I make it go away? (sorry for my non-technical terms)

Posted by mikshaw on Nov. 03 2007,23:18
I haven't tested, but there are two settings in .jwmrc that you could look at.  In the "Tray" tag, you could add the attribute layer=<number>, where number is 0-12. I don't know if 0 is the bottom or top, but you could test it. Optionally you can change the autohide attribute to true.

Still another option is to switch to fluxbox (it's still there) or swm. Swm doesn't have a bar at all.

Posted by danielp on Nov. 04 2007,13:51
Thanks mikshaw for your suggestions. How do you switch back to fluxbox completely?

I tried to modify my .desktop file from jwm to fluxbox, but when I restarted X, I don't get the menu with the righ-click on the desktop, but I get that strange menu from jwm. I guess it must be something to do with the 2nd parameter in .dekstop?

PS: I have a frugal install, and I don't see the way to change back to fluxbox with the menu anymore.

Posted by mikshaw on Nov. 04 2007,14:39
For permanence, use the boot option desktop=fluxbox or backup .desktop

Switching to fluxbox from the jwm menu is all the way at the botton, under the "exit" submenu. The dfm right-click menu doesn't have anything other than dfm-specific stuff.

I can't remember where it is, but roberts answered the no-menu issue just a few days ago...probably either in the DSL4.0 thread or in this forum.

Posted by roberts on Nov. 04 2007,15:19
To turn off the dfm desktop context menu just click and toggle...

DFM for X11 - Desktop conext menu

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.