Autohide not working in jwm

Forum: X and Fluxbox
Topic: Autohide not working in jwm
started by: dslrgm

Posted by dslrgm on Dec. 21 2007,16:13
As danielp noted in

< >

There are some problems with the system tray in jwm.  It lays over any window that extends to the bottom of the screen (and probably top, if you move the tray to the top).

I went to joewing's site about jwm and the only control I could find is autohide which defaults to false.

If I add autohide to the <Tray ... > tag in the .jwmrc-tray file, the tray just doesn't autohide, it is GONE.  Moving the mouse to the bottom of the screen does not bring it up.  autohide=true results in the same behaviour.

Now I WANT the tray.  I am use to such beasts.  But I either want it to go away when not needed, or to be included in the screen available calculation so that when programs like dillo start, their bottom edge is at the top of the tray.

So anyone have tips?  I would go ask on the jwm list, but what version do I say we are running in DSL 4.2.1?

Posted by lucky13 on Dec. 21 2007,16:29
Try adding this in the tray attributes tag. It's always worked for me:


Edit: It still works for me. Just tried it. Have video to prove it.

Posted by curaga on Dec. 21 2007,17:10
Posted by dslrgm on Dec. 21 2007,17:45
Quote (lucky13 @ Dec. 21 2007,11:29)


I had left off the quotes around true when I tried this...

Now it works like WinDOZE with autohide, at least.

It would be nice to have the option of autosize an app to just about the tray.  Like Gnome and WindDOZE....

But as I think about it, there is not that much vertical realestate on my Libretto....

Posted by lucky13 on Dec. 21 2007,17:47
Define what you mean by autosize.
Posted by dslrgm on Dec. 21 2007,19:40
Quote (lucky13 @ Dec. 21 2007,12:47)
Define what you mean by autosize.

Although the real screen size is 800x480, the usable screen size is less whatever system trays consume.  So 'autosize' refers to opening a app so that it is no larger than the usable size.
Posted by lucky13 on Dec. 21 2007,21:47
Look on this page for how to set options according to group tags. My set up is to open things without borders or window decorations since I don't care to use the pointer on this laptop (and certainly not the touch pad on my other laptops) and navigate as much as possible by keybindings. The principle is the same even though you probably only want it to maximize. As you can see by the screenshots, though, there's no need for the title bar or border if you maximize your apps (some need tweaking to work right because they start via script). The GROUP tags I used in those shots are shown about midway down the page.
< >

Edit: You may also want to adjust your layer settings. Apps set on default layer settings will not cover the tray(s) if the tray(s) layer(s) are set on default settings.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.