some help to keyboard i810

Forum: X and Fluxbox
Topic: some help to keyboard i810
started by: kuky

Posted by kuky on May 11 2008,10:47
i can run xfree to config a i810 but my keyboard runs, except alt gr  esc ctrl is a internet keyboard usb wireless twin touch genius in config xfree i started how a pc105 keys...


Posted by Juanito on May 11 2008,11:25
..sounds like a configuration issue in the xfree config file - maybe you could post what you have in the keyboard section?
Posted by kuky on May 11 2008,21:01
the etc/X11/XF86Config-4

the lines uncoment are

Identifier  "Keyboard0"
Driver      "keyboard"
       Option      "Corekeyboard"
Option    "XkbRules" "xfree86"
Option    "XkbModel" "pc105"
Option    "XkbLayout" "es"
i made the first shot with XF86Config-4_vesa file of xFree86.dsl by henk1955

the xfree86 drivers runs in modern hard ?

beers to juanito

Posted by Juanito on May 12 2008,03:50
the xfree86 drivers runs in modern hard ?

- I'm not too sure what you mean by this, does <alt-gr> work now? If not, maybe you could use xmodmap??

Posted by kuky on May 12 2008,09:50
alt gr, control,alt  no works

i asked if its a problem for actual drivers for wireless keyboads?


Posted by Juanito on May 12 2008,11:43
I don't think the fact that the keyboard is wireless has anything to do with it. Does adding any/all of these:
Option "RightAlt" "ModeShift"
Option "XkbLayout" "es"
Option "XkbVariant" "es"
Option "XkbVariant" "nodeadkeys"
.. to the keyboard section of XF86Config-4 help getting <alt-gr> to work?

Have you tried used the command "loadkeys /path-to-file/" before starting X?

Posted by kuky on May 12 2008,23:00
when add the options no result...the same response...

where is to do the second chance...


Posted by Juanito on May 13 2008,04:23
Maybe it is in /usr/lib/kbd/keytables/ or, failing this, you could probably get it from < here > - eg kbd-1.04.tar.bz2?
Posted by curaga on May 13 2008,14:02
No need for the path, "loadkeys es" will do.
Posted by kuky on May 13 2008,22:07
No sucess the line "loadkeys es" is in and is done by control panel - keyboard-es es? also i type in aterm and reinice the windows...

the log in var/log/ xfree86.o
(the begining)
**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Blueriver"
(**) |   |-->Device "i810"
(**) |-->Input Device "Mouse[1]"
(**) |-->Input Device "Mouse[2]"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "es"
(**) XKB: layout: "es"
(**) Option "XkbVariant" "es"
(**) XKB: variant: "es"
(==) Keyboard: CustomKeycode disable

the last lines are

(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
(**) Option "Protocol" "imPS/2"
(**) Mouse[1]: Protocol: "imPS/2"
(**) Option "CorePointer"
(**) Mouse[1]: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse[1]: ZAxisMapping: buttons 4 and 5
(**) Mouse[1]: Buttons: 5
(EE) Mouse[2]: No Protocol specified
(EE) PreInit failed for input device "Mouse[2]"
(II) UnloadModule: "mouse"
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
Couldn't load XKB keymap, falling back to pre-XKB keymap
(II) Server_Terminate keybinding not found
(II) Mouse[1]: ps2EnableDataReporting: succeeded
Could not init font path element unix/:7100, removing from list!

if someone can translate of foreing language...can be apreciated...

pdta. i will send beers to all contributors if its helps the thread and also the ciberbrevery in cool things....

Posted by Juanito on May 14 2008,03:40
I believe you need the file "" which (for example) you can obtain from the file kbd-1.04.tar.bz2 available from the web address I posted above. Once you have the file, load it using the "loadkeys" command and see if that helps.
Posted by curaga on May 14 2008,14:30 is included, I just checked
Posted by kuky on May 15 2008,19:13
no sucess with loadkeys keys works included ٌ but altgr ctrl alt no works...
Posted by Juanito on May 16 2008,04:00
@curaga - do you have <alt-gr> on any of your keyboards? Have you got it to work in dsl?
Posted by curaga on May 16 2008,14:34
All my keyb's are finnish qwerty - they all do have alt-gr. It works for me (using fi-latin9), but only in console, I have no idea why it doesn't work in X..
Posted by curaga on May 25 2008,14:24
Update. I remembered wrong, alt-gr works just fine in tinyX too using vanilla DSL.
Posted by kuky on May 25 2008,20:36
the keyb patch solves the problem ?

can you translate

"works just fine in tinyX too using vanilla DSL"


Posted by curaga on May 26 2008,14:14
No, the patch had nothing to do with this. For me alt-gr started working with the proper keymap, fi-latin9.

Vanilla = without anything added, I just boot "dsl lang=fi" and have it working.
Although due to the fonts being lacking, I can't type هنِ or backticks in an xterm, but I can use other alt-gr requiring symbols such as $..

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.