Topic: Glibc 2.4
started by: gammelmarakuja
Posted by gammelmarakuja on Aug. 28 2007,08:24Hey...I'm just installing some new program (which means as everytime lot of new lib's) and now if got the problem that I need glibc 2.4 and it has to be 2.4 not the one which is in MyDsl cause it is 2.3.6 or sometihnig like that. Has anyone some clue where to find it...i'm already surching the rpm's but ^^ somehow they aren't working.
Posted by Juanito on Aug. 28 2007,09:20You could look for a libc6 debian package >=2.4 and try using that?
Posted by gammelmarakuja on Aug. 28 2007,10:56per apt-get or how? how do i install a deb package? dpkt -i whatever.deb? do you have a link for me?
Posted by Juanito on Aug. 28 2007,11:46If you search these forums on apt-get or dpkg -i there are many threads on the subject but basically you need to load the dsl-dpkg extension and then either:
1. Go to < debian package search >, download the appropriate libc6 (and all of its dependencies) and then dpkg -i libc6*.deb
2. Modify /etc/apt/sources.list to point to debian stable (or whichever release has libc6 >=2.4), apt-get update and apt-get install libc6.
Note that there is a significant chance that you will get several (many?) broken dependency error messages with either of the two methods above.
Posted by curaga on Aug. 28 2007,12:02DSL one is 2.3.2..
Posted by gammelmarakuja on Aug. 28 2007,12:09doen't matter what it is as long it's not 2.4 ^^ but thanks for the correction ;)
Posted by WDef on Aug. 28 2007,16:13As I recall trying to upgrade glibc on dsl via apt-get doesn't work out too well. But maybe I didn't perservere.
Let us know how you get on.
Posted by Juanito on Aug. 29 2007,05:43Looking at the debian site, you would need to get libc6 (v2.6.1) from "testing" as the version in "stable" is 2.3.6 - as WDef says, this is not going to be easy...
Posted by HellesAngel on April 02 2008,10:41Hi All,
First post so first many thanks for DSL as it is. A nice piece of work...
So, to the problem, I'm trying to use the SqueezeSlave audio player from Slimdevices under DSL and get the same error as above. What is the best solution? To upgrade glibc or to recompile the player for DSL?
Posted by Juanito on April 02 2008,10:58Maybe the first step is to try to compile the player on dsl - if you're lucky, it will work with the version of libc6 in dsl.
If you're not lucky, then you have the choice of trying to use dpkg/apt-get for a later version of libc6 (not obvious) or compiling a later version of libc6 on dsl (again not obvious, 1GB of ram was not enough for me to recompile the same version of libc6 as that on dsl, albeit with a frugal install...).
Posted by HellesAngel on April 02 2008,18:59Recompiling anything on the PC I'm using for this player (90Mhz/32Mb RAM) just won't be possible so I'll try compiling on a bigger SuSE box with another older glibc version and keep my fingers crossed... This lib seems to sit at the heart of a Linux system and so should probably be messed around with as little as possible.
Thanks for your reply.