no BootParameters available under windows

Forum: DSL Embedded
Topic: no BootParameters available under windows
started by: B-Schmitt

Posted by B-Schmitt on Nov. 23 2005,14:28
under winxp i don't get a prompt for bootparameter-input.
how do i have to change the .bat?

Posted by adssse on Nov. 23 2005,15:04
Check out the last post in this thread. It has to do with booting into text mode 'dsl 2', but you may find some of this information helpfull.

<;t=9495 >

Posted by B-Schmitt on Nov. 23 2005,15:31
I have read that thread (and already changed my .bat for static bootparams), but I do not know how to change the .bat to enable bootprompt for bootparam-INPUT.
Posted by mikshaw on Nov. 23 2005,15:49
The boot prompt is dependent upon whatever bootloader is used, and I don't think Qemu does it.  If you have DOS scripting knowledge you might be able to add your own prompt to the start of the bat file, but I couldn't help with specifics.
Posted by SaidinUnleashed on Nov. 24 2005,03:21
On the start line in dsl-windows.bat, look for where it says "append" or something, and add your cheatcodes there, although it is already set up for all the emulated hardware that q-emu uses.


Posted by B-Schmitt on Nov. 24 2005,11:28
i used a knoppix with qemu before, there was a prompt for bootparameter input ...
Posted by roberts on Nov. 24 2005,17:24
If you have used Knoppix with Qemu then you could use basically the same windows.bat file.

It is really a Qemu question but the difference is the use of the -kernel option versus the -cdrom option.

For example the dsl-embedded version uses:

REM Start qemu on windows.

START qemu\qemu.exe -L qemu/ -enable-audio -localtime -kernel linux24 -initrd minirt24.gz -hda KNOPPIX/knoppix -hdb qemu/harddisk -append "qemu sb=0x220,5,1,1 frugal quiet"

If you want cdrom behavior then use:

REM Start qemu on windows.
CD qemu

START qemu.exe -L . -m 128 -hda hda -cdrom dsl.iso -boot d -enable-audio -user-net -localtime


Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.