SDL Install Issues

Forum: Games
Topic: SDL Install Issues
started by: Sir Lunch-a-lot

Posted by Sir Lunch-a-lot on Nov. 23 2005,00:38
Hi. I am making another attempt at getting SDL installed into DSL. I am stuck with a winmodem for the time being, so I have to use windows for my internet. As a result, I cannot use the fancy shmancy apt-get function to my advantage.

One other brief hardware note is that I am using a computer which, to the absolute best of my knowledge, is i386 based.

I decided to try installing the .deb files that I already possess for SDL (via DPKG), and it said something to the effect that I have libc6>=2.3.2.ds1-10, but I need libc6>=2.3.2.ds1-21. So, I went to < > in order to find the needed SDL packages AND all their dependancys. However, if would only appear that they offer libc6>=2.3.2.ds1-4 (this was listed as a dependancy under this page: < >

So, before I commit myself to downloading a crapload of big, and potentially useless files, I would just like to know "What gives?". Am I mis-interpreting some of the data? Are some of these dependancys irrelivant in my situation? Does anyone have any tips and advise (other than the obvious "Get a real modem" or "use apt-get" stuff. I've heard that all before, and at the moment, I have no intention of doing the first to allow me to do the latter. Sure... I'd love to have a real hardware modem. Maybe sometime down the road I'll invest in one... but until then...)

Any help or info would be much appreciated. Thank's.

Posted by MethodOne on Nov. 24 2005,16:16
What version of DSL are you using?  DSL 2.0 has support for Lucent Winmodems.  When you set up your connection, the modem port is /dev/ttyS14.  The port is case sensitive.
Posted by mikshaw on Nov. 24 2005,20:25
It might be easier (and smaller) to get a different build of SDL.  The libc dependency is there because of the machine on which the SDL package was compiled.  This is probably the most annoying thing about compiling programs for other systems. More and more distros are using newer versions of libc, which means C programs compiled on those machines will not work on Damn Small without adding newer versions of libs that are already in the distro.  What I've done to deal with this is to keep my older development distro as it is, without updating system files so that programs compiled on it will be dsl-compatable.  This might not be something you can do yourself, so I'd suggest trying to find SDL libs that were compiled on a slightly older distro.  This doesn't necessarily mean that SDL itself needs to be old...just that it's built against an older libc.

Try getting SDL from "oldstable" instead of "stable".  They have libsdl 1.2 built with libc6 2.2.4-4, which should work in Damn Small.

Posted by Sir Lunch-a-lot on Nov. 24 2005,23:43
Thank you very much Mikshaw (almost spelled your name MILKshaw...). That actually makes a lot of sense. I'll be giving that a try.
Posted by Sir Lunch-a-lot on Nov. 25 2005,00:55
BOOYA! It works! It really really works!

I have a mario game that requires the SDL librarys, and so basically that is my test program. It has never run before, but now... It's alive!

Okay, its not all perfect yet. I am still having some minor issues with the SDL mixer... but I am sure that with a bit of effort and tinkering on my part, I'll get it going. If not... I may find myself on my knees, begging the DSL people for help... again...

So, yeah. Thank you very much Mikshaw. You have made my day.  :)

Posted by Veli on Dec. 03 2005,16:22
My Supertux isn't working. Could this be because I don't have SDL? It says something like this:
Code Sample
open /dev/sequencer: no such device or address
Warning: No joysticks are avaiable

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.