italian keyboard problem is fixed!!!


Forum: DSL Tips and Tricks
Topic: italian keyboard problem is fixed!!!
started by: supertux-italian

Posted by supertux-italian on April 30 2006,21:24
hi at all italian and non italian people,the problem of italian keyboard is fixed forever,the solutions is:
in the fluxbox menu select tools>enable apt
download and install apt-get
sudo su
apt-get install xkeycaps
type xkeycaps
configure your keyboard and configure the @ key by press another combination of button,such as shift- or shift- and the problem in fix forever: firefox display and recognize correctly the @ without system reboot or xserver shutdown.
goodbye and good job at all.

Posted by tux222 on May 01 2006,09:12
Quote (supertux-italian @ April 30 2006,17:24)
hi at all italian and non italian people,the problem of italian keyboard is fixed forever,the solutions is:
in the fluxbox menu select tools>enable apt
download and install apt-get
sudo su
apt-get install xkeycaps
type xkeycaps
configure your keyboard and configure the @ key by press another combination of button,such as shift- or shift- and the problem in fix forever: firefox display and recognize correctly the @ without system reboot or xserver shutdown.
goodbye and good job at all.

is not needed enable apt.
open mydsl>system and download xkeycaps (obly 300 kb)
to make permanent the fix,open the file xinitrc with beaver and add:

xmodmap ~/.xmodmap-box

save.
now the fix is permanent saved and work after system shutdown or reboot.

good @@@@@@@@@@@@@@@@@ at all!

Posted by bashbin on May 01 2006,11:39
Quote (tux222 @ May 01 2006,05:12)
Quote (supertux-italian @ April 30 2006,17:24)
hi at all italian and non italian people,the problem of italian keyboard is fixed forever,the solutions is:
in the fluxbox menu select tools>enable apt
download and install apt-get
sudo su
apt-get install xkeycaps
type xkeycaps
configure your keyboard and configure the @ key by press another combination of button,such as shift-[]or shift-[]and the problem in fix forever: firefox display and recognize correctly the @ without system reboot or xserver shutdown.
goodbye and good job at all.

is not needed enable apt.
open mydsl>system and download xkeycaps (obly 300 kb)
to make permanent the fix,open the file xinitrc with beaver and add:

xmodmap ~/.xmodmap-box

save.
now the fix is permanent saved and work after system shutdown or reboot.

good @@@@@@@@@@@@@@@@@ at all!

thank you,i have fix this problem on my machine.
the file xinitrc is located in /home/dsl,i have open it with ted editor

in this file i have deleted the phrase contain "dillo" to disable the dillo splash screen on boot-up.
bye

Posted by pirata on May 23 2006,09:35
I found xkeycaps really weird. Made a mess out of my keyboard (which is Swedish, with ). Anyway, I added this mod to my .xinitrc file:
Code Sample
# My se-latin1 keyboard with mods as follows
xmodmap ~/.xmodmap-my-own &

where .xmodmap-my-own looks like this:
Code Sample
clear Mod4
add Mod5 = Mode_switch
keysym a = a A aacute Aacute
keysym e = e E eacute Eacute
keysym i = i I iacute Iacute
keysym o = o O oacute Oacute
keysym u = u U uacute Uacute
keysym y = y Y yacute Yacute
keysym n = n N ntilde Ntilde
keysym 1 = 1 exclam exclamdown
keysym section = section degree questiondown
keysym aring = aring Aring udiaeresis Udiaeresis
keysym s = s S ssharp


So I get the special letters by holding down AltGr and pressing a key, e.g., AltGr n produces etc.

The first two lines are wellknown to all that have tried to get @ in Firefox :)  

The next 9 lines are good for my Spanish documents (ڿ)  ( maybe not needed ... :O )

And the last two for German ( ) :D

There are a lot more for those who want other characters. You can find them in xkeycaps under the "Edit KeySyms of Key" right-click menu. For instance, if you need Icelandic there are thorn THORN eth ETH etc, Danish and Norwegian have ae and oslash, Portuguese has ccedilla, atilde etc, and I'd really hate to be French in a situation like this (no offense!) Where could you find room on the keyboard for all the aacute, agrave, acircumflex etc... ?  ???

Posted by kuky on June 24 2006,09:15
???

thanks pirata for solve the spanish "acentos" but with the click altgr+e we loss the euro symbol....how to soved it?

Posted by pirata on June 24 2006,22:49
Quote (kuky @ June 24 2006,05:15)
???

thanks pirata for solve the spanish "acentos" but with the click altgr+e we loss the euro symbol....how to soved it?

Well, you could put the on another key, like w or whatever so instead of
Code Sample
keysym e = e E eacute Eacute

you would have
Code Sample
keysym w = w W eacute Eacute


Cent is still on AltGr+c so if you need ccedilla you would have to do something similar....

The best thing would be to have the dead keys working of course... :O

Posted by kuky on June 25 2006,09:08
thanks pirata...

Is possible to combine key alt with e...no key altgr? or keymaps only work with altgr...

Posted by kuky on June 25 2006,20:37
:(         ohh..

there are no symbol  of euro in dsl... when i change to ver 3.0.1 in the original keyboard(es es) when clik altgr+e it put a strange insect of four legs in the screen...

any idea to solved the question..? to import the symbol...

Posted by pirata on June 26 2006,14:11
Quote (kuky @ June 25 2006,16:37)
:(         ohh..

there are no symbol  of euro in dsl... when i change to ver 3.0.1 in the original keyboard(es es) when clik altgr+e it put a strange insect of four legs in the screen...

any idea to solved the question..? to import the symbol...

 ---> Tiene cuatro patas, no puede ser un insecto. Insectos tienen seis patas, segn mi conocimiento... Ni modo :)

It's the currency symbol, or popularly the "sun".

Anyway, the symbol is called "EuroSign" in the keysym language. Unfortunately this code produces nothing in DSL 2.4, which I'm still on. I think it's necessary to use not latin1 but something like latin9 or latin15 for it to work. Not sure, though.

Posted by kuky on July 01 2006,11:05
the euro sign is in Open office, insert especials characters (writte) is not necesary to change keysym e
Posted by winux on Jan. 02 2008,23:26
Quote (tux222 @ May 01 2006,11:12)
Quote

is not needed enable apt.
open mydsl>system and download xkeycaps (obly 300 kb)


Hello

I've got the same problem (I run live CD, not installed yet) with the French keyboard. I did as you say :
keyboard : 105 keys, then
layout : XFree86;French
then button OK
I've got the picture of my keyboard, exactly
then button quit (I don't know if I need to save again, I did not find any button BUT ...

I still don't have my e, a u with spcial sign on top or at the buttom of the lettrer.

Did I do it wrong??? Thx for your help

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.