iso8859-9 problem


Forum: DSL Tips and Tricks
Topic: iso8859-9 problem
started by: usooph

Posted by usooph on Nov. 23 2005,01:38
hi all
I have been trying to figure out how to change language, character set, country settings for a week
no chance
main problem occured with my new application
I wrote it on kylix+ibx (actually delphi clx+ crosskylix)
everything works fine until now
I can see all the buttons and labels in ISO8859-9(TURKISH)
because (my opinion) my application uses its own charset.
But the database related fields like dbedit, dbgrid or any label gets data from db dont show characters correctly.
I couldnt see any tool or option to change lang or charset in DSL. I am using default english iso8859-1 now.
any help appreciated.
thanks

Posted by mikshaw on Nov. 23 2005,04:37
DSL doesn't have built-in language support, and from what I understand it won't have it.  DSL is maintained by a very small group of American English-speaking people....any internationalization will need to be done externally.
Posted by usooph on Nov. 23 2005,06:28
I think u r not aware of dsl 2.0
it has lang option in the boot screen
but it loses the settings after hd install

Posted by mikshaw on Nov. 23 2005,16:01
As far as I know, that is mainly for keyboard support.  Just about everything else is English-only.

As always, someone please correct me if I'm wrong.

Posted by usooph on Nov. 23 2005,16:13
I thought what u said
it is changing all locale settings, not only keyboard
check system status tool, u ll see it

Posted by cbagger01 on Nov. 23 2005,17:36
Yes, but since all of the application-related locale information has been stripped out of the DSL livecd to save disk space, the end result will still be an English-only language system.

Unless you install additional programs via other methods like Synaptic, for exmaple.

Posted by usooph on Nov. 24 2005,06:16
any solutions?
Posted by struppi on Nov. 24 2005,13:04
i don't need german speaking software, but i need on my keyboard. :-D
Posted by JohnML on Nov. 25 2005,09:35
perhaps you just have to change fonts of your application. I had a similiar problem and changed application default font to Times and that worked
Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.