Trying to compile qt4

Forum: Apps
Topic: Trying to compile qt4
started by: Juanito

Posted by Juanito on Oct. 15 2007,06:06
I've been trying to compile qt4 (qt-x11-opensource-src-4.3.0) in order to use it with the dynamic version of skype-1.4

On make, I get the following error - which gets zero hits in google - does anybody have an idea what the problemmight be?
Code Sample
make[1]: *** No rule to make target `kernel/qguieventdispatcher_glib_p.h', needed by `.obj/release-shared/qapplication_x11.o'.  Stop.
make[1]: Leaving directory `/KNOPPIX/usr/src/qt-x11-opensource-src-4.3.0/src/gui'
make: *** [sub-gui-make_default-ordered] Error 2

Posted by stupid_idiot on Oct. 15 2007,08:40
Code Sample
apt-cache depends libqt4-core
 Depends: libc6
 Depends: libdbus-1-3
 Depends: libfontconfig1
 Depends: libgcc1
 Depends: libglib2.0-0
 Depends: libstdc++6
 Depends: zlib1g
Maybe it needs glib2?

Posted by Juanito on Oct. 15 2007,12:50
I was using libglib2.0-0_2.6.4-1_i386.deb, but I wasn't using libstdc++6 or (maybe) libfontconfig1 - thanks, I'll give that a try.
Posted by WDef on Oct. 15 2007,17:19

That may well be it because I think glib2 contains C++.

Posted by curaga on Oct. 16 2007,15:54
libstdc++6 comes with gcc4.. I believe Skype also needs a 2.6 kernel, but I'm not sure..
Posted by Juanito on Oct. 16 2007,16:56
The deb version of libstdc++6 depends on gcc-3.4 & I don't think skype requires 2.6 - the precompiled (but slow) version runs on 2.4 - or at least 1.3.x did.

I'm thinking the problem lies with X somewhere...

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.