libgtk2 mydsl-load failure

Forum: Gtk2
Topic: libgtk2 mydsl-load failure
started by: peterfelts

Posted by peterfelts on May 12 2006,03:47
Hi, whenever I try to load the libgtk2-0705.dsl module as the dsl user I get the following error:

mount: special device /var/tmp/mydsl.icons does not exist
mount: /home/dsl/.xtdesktop: not mounted
ls: /var/tmp/mydsl.icons: No such file or directory

Any one know what would cause this?

I'll see if I can get mydsl.icons from the current.iso, replace the file and try agian.

Posted by peterfelts on May 12 2006,05:06
- nevermind.

I realized that mysld.icons was simply a directory. Once I recreated it the problem went away.


The reason I was trying to install GTK2 was so that I could run eclipse. But now when I launch eclipse I get:

GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/etc/gtk-2.0/gdk-pixbuf.loaders' : No such file or directory

(eclipse:631): Pango-WARNING: **: No builtin or dynamically loaded modules were found. Pango will not work correctly. This probably means there was an error in the creation of:
You may be able to recreate this file by running pango-querymodules.

(eclipse:631): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)` failed

(eclipse:631) ...

I tried to install GTK, PANGO, etc myself the other day, so maybe my OS thinks that certain modules are installed that arent? Perhaps the libgtk that DSL installed is being skipped?

Any help would be appreciated.

Posted by yeti on May 15 2006,17:33

Try right click desktop, mydsl, update to gtk2 before you bring up eclipse.

I had a similar problem with updating Fox.

Hope this helps.


Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.