Update_to_GTK2 do nothing

Forum: Gtk2
Topic: Update_to_GTK2 do nothing
started by: Curtis

Posted by Curtis on June 02 2006,10:34
I have DSL 2.4 and i need to install GTK2.

Te problem is that when i click on Update_to_GTK2 dsl starts openning processes and then close them but do nothing.

I've the dsl installed in a 256Mb DOM. I think i could not have space enough to update to GTK2. I'd like someone to say me if i am wrong or right or if someone could tell me an answer

Thanks  :;):

Posted by ZoOp on June 02 2006,15:11
just load gtk2, update and load an app funtioning with gtk2 (as Thunderbird f.ex.). If Thunderbird loads, then gtk2 has been loaded and updated right.

Posted by Curtis on June 03 2006,14:04
Hi and thanks for replying.

how do i load GTK2?

Posted by ZoOp on June 03 2006,15:08
download the package from the right repository (probably 'system') with mydslbrowser; once downloaded, open emelfm, go to your gtk2-....dsl package (in the repository where you downloaded it), hit 'mydsl' in the front of emelfm (on the top), and you have then the gtk2 libs; after having loaded the libs, menu-->mydsl-->update and it will update the libraries. Then, download and load thunderbird following the same steps first indicated here. If thunderbird loads, it works.

PS just if you would like to get more of the fun of dsl: once a .dsl package loaded, you can't un-loaded it in a single session; .dsl packages are not .uci apps, which you can mount and unmount in a session at your conveniance; the very point in the development of dsl 3.0 RC1 is to realize an .unc extension enabling to convert .dsl packages in .unc packages in order to load and un-load them within a session. So, you see the concept: you have a kernel and modular apps that you can use at your conveniance, depending of what you want to/have to do. It's just a new way of computing.

Posted by cbagger01 on June 04 2006,05:37

You might not have enough RAM or more accurately (RAM + disk swap space) to run the GTK2 extension.

Posted by Curtis on June 05 2006,06:53
OK i'll try bouth things.
Posted by KerowynM on June 15 2006,00:33
Seems a good enough place to ask, considering I just about lost my mind trying to get firefox 1.5 to work. I know about enabling gtk2 but I moved firefox and gtk2 out of optional and for some reason expected gtk2 to load when I booted.  How can I make gtk2 load on boot?  for that matter how can I get my mixer settings to save?  I always have to go in and turn off my input or I get horrible hissing.
Posted by dtf on June 15 2006,00:54
Code Sample
# start up gtk2
/usr/bin/start_gtk2 &

Add the /usr/bin... line to /opt/bootlocal.sh

To get gtk2 started on boot you need to have the gtk2-0705.dsl package in your mydsl directory.  For me that is /mnt/hdc3 and then put the quoted line above in the /opt/bootlocal.sh file.  

I don't have an answer for the mixer settings as I can't get mine save either.

Posted by KerowynM on June 15 2006,01:12
Thanks.  I tried putting "sudo pon" in the bootlocal.sh once before and it didn't work, but I'll give that line a shot.

Edit: Success!  much thanks

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.