Questions about firefox-

Forum: Net
Topic: Questions about firefox-
started by: lesliek

Posted by lesliek on June 27 2006,03:56
I've installed the above (as well as gtk2-0705.dsl) and have two questions about it.

First, as a result of reading another thread about it, I'm now opening firefox by first going to DSL > myDSL and clicking on Update to GTK2 and then returning to DSL > myDSL and clicking on firefox-

Is there any way I can simplify that process of opening firefox v or is that the only method?

Secondly, when I boot up without either firefox- or gtk2-0705.dsl and then run the version of firefox (v 1.0.6) that came with DSL, I can go to a website that has an option for streaming audio in mp3 format. When I click on that option, XMMS opens automatically and plays the stream.

However, when I boot up with both firefox- and gtk2-0705.dsl, get the new version of firefox running and try the same thing, it doesn't work. I get an error message that says, "/tmp/erxb352j.m3u could not be saved, because you cannot change the contents of that folder. Change the folder properties and try again, or try saving in a different location."

I don't really understand what that message is inviting me to do. Is there some way I can get the audio to stream with the new version of firefox?

Posted by Winter Knight on June 30 2006,10:51
What you are describing as "opening firefox" is actually installing gtk2 and then opening firefox. You only have to install gtk2 once, but installing multiple times doesn't hurt. The script to install gtk2 is "/usr/bin/start_gtk2", in case you want to put it in a firefox-load script. When I make the next firefox uci (unless someone beats me to it), I'll have it install gtk2 before it runs.

As for streaming, the firefox 1.0.6 that comes with DSL has several user options set, including a DSL-oriented home page, and several default download actions. firefox- does not have these.

In addition, firefox- (the extension, not the mozilla binary) has a bug. It improperly sets the permissions of your tmp directory. I just noticed that. I'll fix it soon. As a workaround, after you load gtk2 and firefox tar gz, run the following command at a command prompt (be root):

Code Sample
chmod 4777 /var/tmp

This will undo the bug, and all users can once again write to the tmp directory.

Posted by lesliek on July 01 2006,02:20
Thanks very much for your reply, Winter Knight. I don't have access to my DSL computer right now, but will in 24 hours.

I'll certainly try the things you suggest immediately I can.

Thanks again,


Posted by lesliek on July 02 2006,05:21
Here's a brief follow-up report.

Changing the permissions of the /var/tmp directory immediately after opening Firefox got me access to my streaming audio again.

I also understand now that, having already installed GTK2, to open Firefox, I need only click on the firefox- item in the myDSL menu and not on the Update_to_GTK2 item as well.

So all's much like it was before, except that I now have the use of the latest version of Firefox, which is great.

Thanks very much Winter Knight, both for the extension and for helping me with its use.


Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.