I can't boot straight to JWM desktop

Forum: Window Mangers
Topic: I can't boot straight to JWM desktop
started by: ZoOp

Posted by ZoOp on May 20 2006,17:46
Hi all,
I have DSL (2.3) frugal installed on my machine (hda1) with a backup on hda5 (second partition of the same hd) and everything works fine.

I observed that JWM needs 2 processes less than fluxbox and I would like to make my machine directly boot in JWM desktop.

So, I put the cheat code 'desktop=jwm' in my grub boot line, but my machine always boots in fluxbox.

Here is my boot line in grub:

kernel /boot/linux24 root=/dev/hda1 quiet vga=791 noacpi noapm dma noscsi frugal desktop=jwm home=hda5 opt=hda5 mydsl=hda5 toram

How can I get JWM directly at boot?

Thanks a lot for your help!

Posted by mikshaw on May 20 2006,18:49
*edited to correct an inaccurate assumption*

Edit /home/dsl/.desktop: replace "fluxbox" with "jwm"
Then make sure home/dsl/.desktop is included in your backup.

Posted by ZoOp on May 20 2006,21:44

thank you a lot for your prompt answer. I did it, but I have a little problem: when rebooting, dsl makes the backup automatically, so that my the changed /.desktop is replaced with the default one (with fluxbox).

Have I to boot with norestore in order to avoid it...? I guess yes, but I'm not sure; norestore won't load your preferences at boot, but the backup will be done automatically at reboot/shutdown... or am I missing the point?

I don't have time to test it now, that's why I'm doubtfully asking; without any warnings, I shall try it.

thanks again for helping me!

Posted by roberts on May 21 2006,00:00
mikshaw is correct. The file .desktop.
Also you can use the menu to switch desktop to jwm.
The switch desktop updates the .desktop automatically.
When you allow a normal shutdown and the backup occurs it will persist your desktop setting.

Posted by mikshaw on May 21 2006,00:51
ZoOp: I have a feeling that there is a problem with the way you're using backup/restore.  If the modified .desktop file is being overwritten by the default .desktop file, then it's not properly being backed up...it should do the opposite of that.  Another possibility is that you switched back to Fluxbox before shutting down.  If you did that then the backed up .desktop file will have "fluxbox" in it instead of "jwm".

If you use "norestore" your previous backup will not be restored, and you will not create a new backup when you shut down unless you enable your backup again during that session.

Posted by humpty on May 21 2006,05:36
i suggest adding restore=hda5 on your bootline

this will save/restore the backup file backup.tar.gz to hda5.

Posted by ZoOp on May 21 2006,09:20
mikshaw, humpty, thank you so much for your help... and thank you a lot Robert for... the solution! Many many thanks, guys. Again:

1. Robert, it was as simple as you said: when you are in fluxbox, just switch to jwm and then schutdown your machine; dsl backups your setting and at boot, it restores them properly, so that you boot straight to jwm; one told once to me "why do you do things simple when you can do them complicated", well, I did it again...;

2. mikshaw: thanks a lot, it was an elegant solution, but my explanation might be not precise enough; I have DSL 2.3 frugal installed on my laptop on the first partition (hda1) and home, opt, mydsl on the second partition (hda5); in this configuration, I don't have to use the backup/restore utility, because dsl automatically backups my files at shutdown and restores them at boot; that was my problem; when shuting down dsl after being in fluxbox, dsl makes the backup automatically, keeping the settings of the fluxbox desktop in the /.desktop file, because your were there at the last time.

3. and thank you too, humpty, it could be also a possibility, but since I have a frugal configuration with home, opt, and mydsl on hda5 (in my boot line), my files will be restored automatically at boot without adding the 'restore=hda5' cheat code.

As you suggested, mikshaw, I have learned a lot about managing the backup.tar.gz file in DSL. I hope to do it less complicated in the future.

A really happy ZoOp is jumping and singing in his box, not without being less

Posted by pr0f3550r on May 21 2006,10:16
Quote (mikshaw @ May 20 2006,14:49)
The desktop boot option is a Knoppix feature that was not carried over to DSL.

Strange, it works for me.
Posted by mikshaw on May 21 2006,15:16

/me checks .xinitrc....
not there...

/me checks /etc/init.d/dsl-config....
...oooooooh.... :D

/me edits previous post
thanks for the correction, pr0f3550r

Posted by andrewb on May 22 2006,07:17
Check to see that you don't have the file backup.tar.gz on hda1 (or 2, 3, or 4). It may be that you ran the backup before & there is an old copy of this file lying on an earlier partition than hda5. If this is the case this other backup file will be used, even though the backup is made to hda5. All you need to do is delete or rename any other instances of backup.tar.gz except the one in the root of hda5.

I think what may be happening is that you have a an old version of backup.tar.gz without the .desktop file in it on hda1/2/3 or 4 & the restore function is finding that. In this situation you will always end up with the default .desktop (& any other files you add to .filetool.lst will also not be restored correctly).

As you say this won't affect your home & opt directories as they are persistent anyway (unless you did back-up some files earlier using backup before you presumably edited .filetool.lst to remove /home & /opt entries - in this case the files will be restored & you will notice problems if you change them as the 'original' will be replaced every time you reboot).

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.