fluxbox 1.0

Forum: Window Mangers
Topic: fluxbox 1.0
started by: mikshaw

Posted by mikshaw on Oct. 12 2007,04:12
I've been playing around with the new fluxbox 1.0 release today, and I'm happy to say that they fixed the main issue that was pissing me off since 0.9.15.

One thing I still find annoying is that setting backgrounds from a style now requires the fbsetbg script rather than using whatever app the user chooses. This script is pretty cool in that it works with several different applications, but for use in DSL it is very bloated. DSL uses mainly just xsri, so I decided to cut down the script to use only xsri. So far I have it at a point where it uses only xsri for images, but it still uses fbsetroot for solid colors and gradients. I'm hoping to eventually make it use only xsri so i can delete the fbsetroot app and save a few more Ks. The current fbsetbg script is about a quarter the size of the original. This is totally legit according to the license under which it was released, but I'm curious if it is an acceptible change for a mydsl extension. I haven't tested it thoroughly yet, but I will continue testing for a while before submitting the extension.\

If I knew anything about C programming I'd probably modify the source to use xsri instead of fbsetbg, but my knowledge limits me to changing the wrapper script.

Posted by ^thehatsrule^ on Oct. 12 2007,06:01
Why not?  However, I tend to include scripts that I have created in mydsl extensions (that I'm "learning" on) as separate scripts, or even in another extension.
But the way I see it with the extension policy right now is that pretty much anything goes...

Btw, what was that issue that was bugging you?
(I've been using the RC's so maybe I missed something)

plus you could always start an attempt at C :p

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.