problem with IceWM

Forum: Window Mangers
Topic: problem with IceWM
started by: SmartUnixٍ

Posted by SmartUnixٍ on Nov. 01 2005,09:57
Hello ..

i installed IceWM , when i login in root and try to install it the system requiest from me to login with dsl use and install it .

i did and i installed it , but now i have problem :(

when i login with root and i use right click to show menu i don't found "myDSL" menu (like dsl) , so i can't use IceWM with root account .

what should i do to use IceWM with root ?

Posted by mikshaw on Nov. 01 2005,14:58
The mydsl system is made for user dsl, which means that's the only user that automatically gets mydsl menu and icons added automatically.
IceWM is a window manager, and so it probably doesn't have a menu item for anyone (unless it runs a script to set up your system to use it?).

In order to use it as root, you'll probably need to create a file called /root/.xinitrc and add icewm to that.  However, I recommend that you reconsider the use of a gui as root.  For one, it's a lot easier to destroy your system with a point-and-click environment than with a console. Also, I hear it's less secure...though i don't have any facts to back that up. Third, there is no benefit to DSL anything you can do logged in as root can be done with sudo, and you lose some of the features that were designed for dsl.

Posted by Your Fuzzy God on Nov. 01 2005,15:28
Try the script < here > to convert the Fluxbox menu to IceWM.

Good Luck,

Posted by SmartUnix&#1613; on Nov. 01 2005,16:00
Hello ..

ok i tried to run IceWM with dsl account but i have problem ???

the icons don't show in desktop ?

Posted by SmartUnix&#1613; on Nov. 01 2005,16:15
Hello ..

i notice thing and i tink it's bug ! :O

when i login with dsl (of course using IceWM) the icons don't show in desktop , but when i click right click in mouse the menu show with all programme .

when i do "Alt+Ctrl+Del" then i do "su" and type root password then do "startx" the icon will show in desktop , but when i click right click the programme in menu don't show !!!!!

Posted by Your Fuzzy God on Nov. 01 2005,19:19
The icons are not drawn by Fluxbox or IceWM.  They are drawn by the program xtdesk.  There are normally three reasons why these icons are not displayed.

1.  You are not running xtdesk.  Solve: Make sure the line " &" is in your ~/.xinitrc file (for v1.5 and above.  I can't remimber where they used to be before that).  This line is normally in an if statement such as:

Code Sample
if egrep -qv noicons /proc/cmdline 2>/dev/null; then &

2.  You do not have your icons enabled.  Solve:  Right click on desktop-->Use full enhanced desktop

3.  You are missing an image file for one of your icons in the ~/.xtdesktop folder.  Solve: Make sure that each .lnk file has a corresponding image.  Open each .lnk file and checking the 'Icon:' line. Make sure that the image that line refers to is available.

Good Luck,

Posted by SaidinUnleashed on Nov. 01 2005,19:24
And, the image and .lnk files MUST have the same name, ie myprogram.lnk and myprogram.gif.
Posted by SmartUnix&#1613; on Nov. 03 2005,13:51
Hello ..

ok where i can find xinitrc or xtdesktop files ?

Posted by mikshaw on Nov. 03 2005,15:42
In /home/dsl

They are "hidden" files, also known as "dot" files because the filename begins with a dot.  You can see them in mc by default.  In EmelFM either press the "H" button next to the location bar or press Ctrl+h

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.