DSL v3.2 Errata

Forum: Site News
Topic: DSL v3.2 Errata
started by: roberts

Posted by roberts on Jan. 24 2007,15:16
Symptom:  rtl8139 netcard no longer works
Affects:     traditional hard drive installaions
Solution:   copy the prior b44.o from v3.1 and then run depmod -a

So, in fact the steps necessary to correct this issue

First place your DSL v3.1 or prior CD into machine. Then perform the following...

# mkdir /mnt/test
# mount /mnt/auto/cdrom
# mount /mnt/auto/cdrom/KNOPPIX/KNOPPIX /mnt/test -o ro, loop=/dev/cloop60
#cp /mnt/test/lib/modules/2.4.26/kernel/drivers/net/b44.o /lib/modules/2.4.26/kernel/drivers/net/.
#depmod -a
#umount /mnt/test
#umount /mnt/auto/cdrom
#modprobe 8139too

If you like you can cut and paste then run this script.

Posted by roberts on Jan. 24 2007,15:18
Symptom:  mkmysl exits with errros
Affects:       mkmysl

There is a typo in the script but it does not affect the creation of the iso image. It does affect the last prompts to ask if you want to burn the iso. The line is at about 155 where I typed ( when I ment a {

echo "$(WHITE}If you have booted ...

That opening ( should in fact be a {

echo "${WHITE}If you have booted...

You can copy the script from /usr/sbin/mkmydsl to your home dir and make this trivial mod and then run from there

$ sudo ./mkmydsl

Posted by roberts on Jan. 24 2007,15:28
Symptom:  frugal_lilo install using the install from iso file option
Affects:     only when trying to install from [I]so file option of frugal_lilo.sh

There is a typo and use f instead of i

I tested the i/f option and found a problem. Seems some of my changes from frugal-grub did not get propagated back to frugal lilo. Anyway here is the change needed.

Look for the line

Add this line just below it:

I just ran with this mod and successful in installing frugal lilo to hdd1 compact flash using the install from file option.

Posted by roberts on Jan. 24 2007,15:35
Sympton: Emelfm As Super User
Affects:   Joe's window manager

Edit the file .jwmrc and look for this line
<Program label="emelFM as super-user"> sudo su -c emelfm </Program>

and change it to:  

<Program label="emelFM as super-user"> sudo su emelfm </Program>

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.