Xmms Settings?

Forum: Multimedia
Topic: Xmms Settings?
started by: thingumybob

Posted by thingumybob on Oct. 25 2007,17:21
Please bear with me this is my first post, and I have searched for days for the answer.

When playing MP3s through Xmms, the sound is good; but, there is a slight static sound.  Also when I play CD audio, the sound is pretty bad altogether.  I don't get any errors, it just doesn't sound worth listening to.

Under System Stats, DSL reports:

SOUND_FULLNAME="Creative Labs | ES1371"

In Xmms under Preferences>Audio I/O Plugins>Output Plugin>

OSS driver 1.2.8 [libOSS.so]

As far as I can tell, the IRQ for the sound card is 11.  The BIOS won't let me choose what IRQ to set it for.  There are only two settings for each IRQ and they are something like PnP or ISA/VESA (something like that, I have to reboot the computer to get the exact wording).

I have a question about using the ALSA output driver, but I am going to wait until I get a response to this question first.

Any help would be greatly appreciated, I am going blind reading posts that have almost no relevance to my problem.   ???

Posted by mikshaw on Oct. 25 2007,19:45
enabling dma for your CD drive, if it's IDE, might help the CD audio (sudo hdparm -d1 /dev/cdrom)
Posted by thingumybob on Oct. 25 2007,21:09
Thanks for the tip.  I tried typing that line in Bash and it came back with:

operation not supported on SCSI disks

I think I'm doing something wrong.  I don't think this is an SCSI disk.  Should I be insterting that command somewhere or will it work from a terminal prompt?

Posted by curaga on Oct. 26 2007,13:10
Boot with "dsl idecd dma" to use ide drivers instead of scsi, and to automatically enable dma.

For the static sound, I had that with an old opl3-sa2 isa card. What caused that was the Bass channel set to ~50, and with lousy speakers, the bass boost came out as static sound. So try turning the Bass, Discant, and all "line in" channels down..

Posted by thingumybob on Oct. 26 2007,18:32
Thanks for all the help.  I changed the line:

kernal /boot/linux 24 root=/dev/hda1 quiet vga=normal noacpi noapm nodma noscsi frugal


kernal /boot/linux 24 root=/dev/hda1 quiet vga=normal noacpi noapm dma noscsi frugal

DSL came back with:

Enabling DMA acceleration for hda [hard drive type here]
Enabling DMA acceleration for cda [CD ROM type here]

So that part worked, but it didn't change the quality of the sound coming from the CD audio.

Then I tried something totally unexpected... I tried a different CD.  It sounded fine.  So after all this mess I came to the conclusion that my problem is the media I'm trying to play.

The MP3s were downloaded from a questionable site which will remain unnamed, and the audio CD was a copied CDR.  The CD that sounds fine was purchased from Amazon.com.

I'm going to put it down as a nonissue.  Just because these MP3s and burned CDRs sound fine on other players isn't really Xmms' problem.

I'm sure once the newbie stank wears off me, I'll realize just why this questionable media doesn't sound perfect.   :cool:

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.