unable to move/copy more then 2G to another linux

Forum: Networking
Topic: unable to move/copy more then 2G to another linux
started by: =SERGE=

Posted by =SERGE= on Aug. 13 2008,16:09

very strange... I gownloaded an iso image 3.7G (slackware dvd install) with dsl 3.4.smth. Then I wanted to copy/move it to another linux computer with ext3 fs. I never succeded. Only 2G can be copied/moved with emelf and mc.

How this can be explained?

Thank you

Posted by curaga on Aug. 13 2008,16:32
How did you try to move it? USB stick?
Posted by =SERGE= on Aug. 13 2008,16:34
through the cable, TCP/IP, w ordinary 100mbit 3com cards...
Posted by mikshaw on Aug. 13 2008,17:07
It's possible that those file managers were built without large file support (2gb is the cutoff point).  The mc.uci mydsl package *should* be able to do it, though I can't recall ever trying to copy large files.  Another option is to try cp, or ftp
Posted by curaga on Aug. 13 2008,17:54
I wonder if Busybox in DSL is with or without large file support?
That would leave ftp..

Posted by WDef on Aug. 13 2008,18:05
Does the connection get dropped when the file transfer fails?

If so it may be some network related problem.  Are the computers just plugged in to one another or is there a network in between (eg the internet).

Not sure if this is relevant:  http://osdir.com/ml/os.openbsd.tech/2002-04/msg00120.html

That thread talks about fragmentation problems, hardware problems, or the operating system running out of buffers (what is meant by NMBCLUSTERS on OpenBSD).

The equivalent to upping NMBCLUSTERS for linux is to open a root shell and do:

Code Sample
# sysctl -w net.ipv4.tcp_mem='98304 131072 196608'

(though now I can't see what the default for that key was since I've changed it on my box).

You could do that on both machines and then try the big file transfer again.

There are detailed TCP tuning instructions for high bandwidth 2.4.xx linux here:

< http://wwwx.cs.unc.edu/~sparkst/howto/network_tuning.php >

Disclaimer: I don't know much about networks.

Posted by chaostic on Aug. 13 2008,19:40
If you have the spare room (another 3.7 gb on both machines), use spilt then cat.

usage: split [-b byte_count] [-l line_count] [-a suffix_length] [file [prefix]]

split -b 1000m slack.iso slack

And you should get about 4 1000mb files named

(Or slack.001 - slack.004, or the like)

Then after you transfered the files, on the target machine, use cat slack.* > slack.iso

You might want to run a md5 on both computers to check afterwards, but it's not needed
"md5 slack.iso" on each machine then compare the two numbers.

Posted by =SERGE= on Aug. 13 2008,20:25
well, it's simple
when trying to copy/move with mc
from a partion on dsl to a partion from another linux mounted through samba in dsl tree
the output is

file size limit exceeded

both patitions are ext3

Posted by =SERGE= on Aug. 13 2008,20:39
here below:

dsl@box:/mnt/hdc1/slackware-12.1-iso$ mv /mnt/hdc1/sl*/slackware-12.1-install-dv                                           d.iso /home/dsl/mnt/SL*/320disk
File size limit exceeded

Posted by ^thehatsrule^ on Aug. 13 2008,21:39
Could be a samba limitation.  How did you mount it? (quick search around shows "-o lfs" might do the trick)
Posted by WDef on Aug. 14 2008,22:08
Did you try increasing your TCP buffer size with sysctl or did I waste my breath posting?
Posted by =SERGE= on Aug. 15 2008,06:25

thanks a lot for reply

there have been two possible explanations to the 2G limitation:

1) samba limitation
2) tcp buffer size

It's been now many years I deal with linux (I'm still newbie)
I never heard of samba limitations and never encountered such limitations. I never had to have recorse to tcp fine tuning to transmit over home network 4G.

In my home network there are several computers and only one with XP and one with DSL.

The problem is that DSL refuses to send more than 2G to another machine Linux or XP

DSL says (or rather bash):

dsl@box:/mnt/hdc1/slackware-12.1-iso$ mv /mnt/hdc1/sl*/slackware-12.1-install-dvd.iso /home/dsl/mnt/SL*/320disk
File size limit exceeded

It means that the system knows the problem

It remains to find out where this file size limit comes from?

thank you


Posted by WDef on Aug. 15 2008,09:13
Well, we are suggesting things because we don't know for sure.  This isn't kernel hacker central y'know.

And Serge, it will help if you tell us the outcome of trying things we have suggested.  You haven't done that.  Did you remount your Samba share using the -o lfs option?  You haven't said.

System limitations: process and resource limits that the system knows about can be seen and re-set with the ulimit command.

Can you please post the output of the following commands:

Code Sample
$ ulimit -a

Code Sample
# sysctl -a | grep net.ipv4.tcp_mem

I think the most likely thing though, as had been suggested, is that something has been compiled without large file support and it's never come up before for some reason.

Have you tried moving the file without samba? You haven't said.  For example, running monkeyserver on dsl and downloading it via your browser on the other machine, or by ftp?  That would tell us whether samba is the culprit or not.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.