Screen has yellow-ish tinge to it

Forum: Laptops
Topic: Screen has yellow-ish tinge to it
started by: tra4d

Posted by tra4d on Oct. 13 2006,22:12
I have done a DSL hdd install on my IBM Thinkpad 310ED.  Everything is ok but the display has very poor color.  There is a yellowish tinge to the display (only in DSL, not the IBM splash screen and not the DSL splash screen when booting from CD).  Anybody have any idea how I can fix this?

I am guessing its the resolution/color depth but I am not sure how to set it (other than using vga=771 which is what I have it set to).  Images are also poorly displayed (bad color).

Any help would be greatly appreciated.


Posted by ^thehatsrule^ on Oct. 13 2006,22:32
Seems to suggest 640x460x16 as a start in:
< >

Posted by Juanito on Oct. 14 2006,04:46
See < >
Posted by tra4d on Oct. 16 2006,13:09
Thanks for the responses.  Here is what I found:  I boot using cheatcode vga=771 and the colors are no good (this is what I have been doing).  If I then run and and select xfbdev (which I selected during hdd install so I am pretty sure I am currently using this), and startx, everything is fine.  Any ideas how I can keep these settings?
Posted by Juanito on Oct. 16 2006,13:44
You should set up backup/restore (if you didn't already) and add the file .xserverrc to .filetool.lst

Once you have run, you should see something approximately like the following in .xserverrc:

exec /usr/bin/X11/Xvesa -2button -mouse /dev/psaux -screen 1024x768 -shadow -nolisten tcp -I &>/dev/null

Posted by tra4d on Oct. 16 2006,14:58
Ok.  After I ran my .xserverrc had the following:

Code Sample

exec /usr/bin/X11/Xfbdev -2button -mouse /dev/psaux -nolisten tcp -I &>/dev.null

I added -screen 800x600 and removed the boot option 'vga=771'.  I get the following error:

Code Sample

Using X resolution from previously selcted of default settings.
If you want to change the resolution, run ''

giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error

Posted by ^thehatsrule^ on Oct. 16 2006,15:32
Why did you remove the vga=771?

Anyhow, after running and choosing what you prefer, there's no need to manually add options... just back the file up.

Posted by tra4d on Oct. 16 2006,15:41
back the file up?  You mean make a copy of it somewhere safe or do you mean something else?
Posted by tra4d on Oct. 16 2006,15:52
I took out the vga=771 because I thought it might be overriding the .xserverrc setup and/or it might be the wrong code.  I have put it back in.  Here is what I have done:

inside my /boot/grub/menu.lst is the following:
Code Sample

kernel /boot/linux24 root-/dev/hda2 quiet vga=771 noacpi noapm nodma noscsi frugal

Inside my /home/dsl/.filetool.lst is the following:
Code Sample


(where I added the fiinal line)

and my .xserverrc file is:
Code Sample

exec /usr/bin/X11/Xfbdev -2button -mouse /dev/psaux -nolisten tcp -I &>/dev.null

The colors are still incorrect.

Posted by tra4d on Oct. 16 2006,15:59
But..  if I reboot, wait for the desktop to load, then open a shell and type startx, then the color is fine.  Its almost as though the settings are not getting saved, or not getting started properly.
Posted by ^thehatsrule^ on Oct. 16 2006,16:51
I suppose "home/dsl/" already covers "home/dsl/.xserverrc" - don't know if that matters or not, though.

For backup/restore info, see:
< >
< >
or the first page that pops up under dillo.

btw, there's an edit button to avoid those double/triple forum posts.

Posted by tra4d on Oct. 16 2006,17:37
Quote (^thehatsrule^ @ Oct. 16 2006,12:51)
I suppose "home/dsl/" already covers "home/dsl/.xserverrc" - don't know if that matters or not, though.

So, if having "home/dsl/" inside my filetools.lst file saves the settings, then any ideas why this is not working?

This is very confusing since the colors are wrong when I boot, but simply opening a terminal window and typing 'startx' fixes the color (w/o running first).

Its almost as if X has to be started a second time.?!

Posted by ^thehatsrule^ on Oct. 16 2006,20:14
I'm guessing you're running 2 X sessions, one on the top of the other - so it'll just take up more resources.

Question: when you were testing with , did you restart X or open another X session?

Posted by tra4d on Oct. 16 2006,20:22
Yes, I am running 2 X sessions.

Yes, when testing with I started another X session 'on top' of the current X session.  But I have found that I don't actually have to run the to get it to work (i.e. allow desktop to boot, then open terminal and type 'startx' and all the colors are good).

Posted by ^thehatsrule^ on Oct. 17 2006,14:54
To test the screen with just 1 X session with, you can do:
1. run, choose options
2. close X (ctrl+alt+backspace, or menu>Window manager>exit)
3. startx
4. If the screen is still messed up, repeat 1-3.

Posted by tra4d on Oct. 17 2006,15:38
I have tried all that.  It seems that I have to start the x server twice (and I don't change any settings) to get the colors to display properly.
Posted by tra4d on Oct. 17 2006,17:15
I tried booting from live cd and get the same results.  

1.  Insert CD and boot
2.  When prompted for boot options:
       fb800x600 dsl vga=771 minimal
3.  Go through setup
4.  Desktop boots but colors are whacked
5.  Open xshell, type in 'startx' <enter>
6.  Second X sessions starts and color is good


Posted by roberts on Oct. 17 2006,21:07
You have conflicting options on that boot line.

I can reproduce a Greenish/Yellow screen using vga=771 on my Thinkpad 240 using the Xvesa server.

I need to use the alternate Xfbdev server. Many older laptops need the Xfbdev server

Also, if you were talking before of booting from a hard drive install then a pre-existing .xserverrc would mess things up.

From booting the DSL CD try this:

boot: dsl base norestore xsetup

Choose Xfbdev, the framebuffer and select select an appropriate resolution and depth, for my TP240 it is 800x600 32

My .xserverrc file looks like this:

exec /usr/bin/X11/Xfbdev -2button -mouse /dev/psaux -nolisten tcp -I &>/dev/null

My TP240 only has a two button mouse.

You should not have to edit this file as it is generated via the script.

Posted by tra4d on Oct. 18 2006,15:32
Thanks for the reply.  Ok, when using 'dsl base norestore xsetup' at boot with CD, I get error:

'You passed an undefined mode number.  Press <RETURN> to see video modes available...'

I then select '0' for 80x25 columns which is what the error message seems to be displaying with.  Things go well until after the xsetup I get the error:

'modprobe: modprobe: Can't locate module fb0
XIO:  fatal IO error 104 (Connection reset by peer) on X server "0:0" after 0 requests (0 known processed) with 0 events remaining.'

I then searched forum and found this post:
< >

But it didn't help since I tried the cheat codes and from what I gather, your post says I shouldn't be using them.

BTW: when choosing frame buffering option in xsetup, I am not presented with the option of selecting screen resolution.

Posted by roberts on Oct. 18 2006,15:47
OK try this:

boot: fb800x600 base norestore

If still no framebuffer device then try...

The undefined mode can usually be avoided with vga=normal

If you cannot run framebuffer, then try various Xvesa options.

boot: dsl base norestore vga=normal xsetup

It might well be the case that you will need to run the full XFree86 extension.

The incompatiable options you had posted was the fb800x600 and vga=771. The fb800x600 implied vga=788 which conflicted with 771. Also the fb800x600 imples the frambufer.

By starting out with the nobase norestore we are sure that no stored prior choices would also be causing a problem, i.e., no prior .xserverrc.

Posted by tra4d on Oct. 18 2006,16:03
That was better but still the color is yellow and the icons are not showing up.

If I try 640x480 16-bit (either with cheatcode 785 or by setting up in xsetup on boot choosing Xvesa) it works flawlessly and I get my icons, and color is great.  But the screen is quite small.

But, if I try 800x600 (16-bit or 8-bit makes no difference) then I get the yellowish screen and no icons.  Very wierd.

(I tried the XFree86 a bit but couldn't get it to boot with the config file I made with xf86config package - maybe I will have to keep trying that if I can't get this to work)

Posted by roberts on Oct. 18 2006,16:11
Try the framebuffer one more time from the CD:

boot: fb800x600 base norestore

and choose framebuffer

Posted by tra4d on Oct. 18 2006,16:16
I get the undefined mode number error again.  I choose option '0' and then after xsetup (choosing Xfbdev) I get same modprobe error again.   :(
Posted by roberts on Oct. 18 2006,16:27
Some machines will require XFree86.
I have one like that too. Using the default tiny X server I get a small screen with wide black borders.  Using the full XFree86 then I can get full screen.

Posted by tra4d on Oct. 18 2006,16:32
Its wierd since windoze ran fine 800x600.
Posted by NoobieDoobieDo on Feb. 04 2008,17:52
I had this same problem on my Thinkpad 240.  I finally found that setting the video mode in grub to read vga=789 got me a resolution that worked.

Good luck

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.