stop screen blanking

Forum: Laptops
Topic: stop screen blanking
started by: vstech

Posted by vstech on Oct. 30 2007,18:17
Hi All...

I have made a digital picture frame from an old IBM Thinpad 600e.  For the most part, things are working they way I want them, execpt the screen goes black after about 10 minutes.

I have researched the forum, and have placed the noapci noapim apm=off cheat codes in the grub menu. I have also edited the .xinitrc to have xset x off and noblank in the script, but there has been no change.

I have changed the hard drive to run windows and use IBM's configuration utility, and the bios (as near as I can tell) is set to always have the screen on (power always on).

What setting am I missing or have wrong?

Thanks in advance.

Posted by ^thehatsrule^ on Oct. 30 2007,19:11
Which xserver are you using?  Did you try xfbdev?

Also, can you "resume" the screen after it has gone blank?

Posted by vstech on Oct. 30 2007,20:01
I am  using the default xserver, with fluxbox.  No, I have not really tried xbdev.... I will try it again to see if it makes a difference.

Yes, it resumes properly after the screen goes black by moving the mouse or pressing a key


Ok, I tried xbdev... I can configure it, but I get an error and it can't continue to load fluxbox when I reboot and have the system set to use it.

Posted by robc on Oct. 30 2007,20:29
shouldn't it be "xset s off" or "xset s noblank"?
Posted by vstech on Oct. 30 2007,21:36
I tried both variations, robc. I found scripts with those commands on dsl site or the forum, I forget wich.

They did not seem to make a difference.

I did note that when I had the HD with Win98 on it in the laptop that the screen did not shut off.  So, I assume it must be an xserver setting somewhere.

Posted by ^thehatsrule^ on Oct. 30 2007,22:33
Try adding acpi=off (possibly pci=noacpi too) to those bootcodes?
Posted by vstech on Oct. 31 2007,04:12
Quote (^thehatsrule^ @ Oct. 30 2007,17:33)
Try adding acpi=off (possibly pci=noacpi too) to those bootcodes?

Great!  One of those codes did the trick (I added all of them).. not sure which worked, but it worked!

Thanks again for everyone's help...

Posted by ^thehatsrule^ on Oct. 31 2007,05:08
It was probably noapci acpi=off... the 600e was reported to have a buggy bios with acpi.
Posted by bkil on Oct. 31 2007,09:03

There is another solution. If you install the full xfree86 server extension, you could give this a shot:
Code Sample
xset -dpms

Do note, that with 24/7 use, your TFT's backlight will probably give up in a year or two. It's not very expensive, but it is difficult to both obtain and replace.
Another note: couldn't you find a nice old 386 or 486 for the job? You know, a P2 is a terrible thing to waste, IMO. :(


Posted by vstech on Oct. 31 2007,12:18
The IBM thinkpad's are nice machines, I will give you that.  But, I found a bunch of old ones (taking parts from some to make usable machines).   Although.. I have two machines, one with a broken screen, the other with a good screen bad motherboard.... same model number, but the good board won't run the good screen!!

Go figure!

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.