Enable apt in DSL 3.3

Forum: Apt-get
Topic: Enable apt in DSL 3.3
started by: Juanito

Posted by Juanito on June 01 2007,12:56
I just used the right-click menu item "Enable apt" for the first time in a long time with DSL 3.3.

I noticed that the script downloaded the dsl-dpkg.dsl extension - shouldn't it download the dsl-dpkg.unc extension unless you're using a legacy boot?

Posted by ^thehatsrule^ on June 01 2007,14:38
Yea, it would be wise to update that...

The scripts I'm using do something like:
Code Sample
lsmod | grep -e "^unionfs "  # and/or use `mount`?

cat /proc/cmdline | grep " legacy "

Of course using using case statements is probably better for performance, but it's shorter to write here.  Then I have some error checking... such as
Code Sample
but could be left out for this topic's purpose, since I made my scripts to be backwards-compatible with older DSL releases.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.