Problem installing perl with apt

Forum: Apt-get
Topic: Problem installing perl with apt
started by: Azariel

Posted by Azariel on Nov. 20 2004,16:06
I'm an apt newbie, but a moderately experianced linux user.

I installed DSL from the ibiblio mirrior using the DSL single floppy/web install method. I assume this means that I have a pretty recent copy.

I'm trying to install the perl package so that I can install apache and oddmuse wiki. When I use apt-get install perl, I get the error message

The following packages have unmet dependencies:
  perl: depends perl-base (=5.6.1-8.7) but 5.8.0-18 is to be installed
E: broken packages

Does this mean perl wants an older (5.6.1-8.7) version of perl-base to be installed? Or does it mean that the perl-base is 5.6.1-8.7, but perl 5.8.0-18 was going to be installed?

Attempting to uninstall perl-base provokes a long and threatening warning message that includes a mention of perl-base taking LILO with it when it goes. Needless to say, that would be suboptimal.

If anyone can offer a pointer on how to tackle this, I'd appreciate it.

Posted by ke4nt1 on Nov. 20 2004,16:40
Did you try using " apt-get install perl perl-base "  ??

It looks like perl thinks it will break, having a perl of 5.8.0 and a
perl-base of 5.6.1..  This command should fill apt dependency needs.

Are you using the "unstable" apt repository in your sources.list?
If not, try that too, as it may well upgrade both when you run
" apt-get install perl "

And since DSL is not "pure" debian, don't be surprised if you
see these types of errors when installing apache and your wiki ..


Posted by MikeY. on Dec. 09 2004,05:14
I'm also trying to get apache installed, I did not have any luck with the apt-get install perl per-base suggestion above... any other ideas?

Thanks in advance.

Posted by deleric on Dec. 30 2004,00:02
Try this:

apt-get -testing install perl-base

It gives me:


root@box:/home/dsl# apt-get -testing install perl    
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
 libdb4.2 libgdbm3 perl-modules
Suggested packages:
The following NEW packages will be installed:
 libdb4.2 libgdbm3 perl perl-modules
0 upgraded, 4 newly installed, 0 to remove and 147 not upgraded.
Need to get 5829kB of archives.
After unpacking 23.3MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 < > testing/main libdb4.2 4.2.52-17 [388kB]
Get:2 < > testing/main libgdbm3 1.8.3-2 [21.3kB]                                                
Get:3 < > testing/main perl-modules 5.8.4-3 [2182kB]                                            
Get:4 < > testing/main perl 5.8.4-3 [3238kB]                                                    
Fetched 5829kB in 1m31s (63.9kB/s)                                                                                  
Selecting previously deselected package libdb4.2.
(Reading database ... 10808 files and directories currently installed.)
Unpacking libdb4.2 (from .../libdb4.2_4.2.52-17_i386.deb) ...
Selecting previously deselected package libgdbm3.
Unpacking libgdbm3 (from .../libgdbm3_1.8.3-2_i386.deb) ...
Selecting previously deselected package perl-modules.
Unpacking perl-modules (from .../perl-modules_5.8.4-3_all.deb) ...
Selecting previously deselected package perl.
Unpacking perl (from .../archives/perl_5.8.4-3_i386.deb) ...
Setting up libdb4.2 (4.2.52-17) ...
Setting up libgdbm3 (1.8.3-2) ...
Setting up perl-modules (5.8.4-3) ...
Setting up perl (5.8.4-3) ...


Posted by Stuart Leask on Mar. 12 2005,18:39
I have the same problem.

The lickety-slick DSL v1.0

I try apt-get-ting r-base r-base-core and r-recommended, and it tells me
r-base-core: Depends: perl but it is not going to be installed
I add perl, and it tells me :
Depends: perl-base (= 5.6.1-8.7) but 5.8.0-18 is to be installed perl to the list

And the suggestions above don't seem to change this situation...

Help! I can't begin to describe how cool it'll be to stroll around at work doing my analyses on as powerful machine I need, while my colleagues are stuck with their WimxP 'workstations'...

Posted by Gary Whysong on Mar. 24 2005,20:11
I have the same problem. I wanted to add R to my hd dsl installation and had to give up.

I thought it would be really cool demonstrating how to do statistical analyses to students in my Grad. Statistics course (Windows users) using dsl on an ancient IBM laptop. DSL runs quite fast in ram on an old 366 Mhz machine.

Any suggestions would be appreciated.

Posted by Hannes on April 03 2005,11:49
Uncomment all the lines (remove the #) in



apt-get update
apt-get -testing install r-base



Posted by mike on April 04 2005,23:57

Works great, I did have to run "apt-get -testing install r-base" twice to get packages installed, but all went well. Now can run Cross-over Office.

Thanks, Mike

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.