Search Members Help

Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic
Pages: (4) </ 1 [2] 3 4 >/

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: French keyboard ... still pending, sorry, Special letters do not work< Next Oldest | Next Newest >
winux Offline

Group: Members
Posts: 69
Joined: Jan. 2006
Posted: Jan. 06 2008,00:16 QUOTE

Hello guys

Actually it's not as fine as I thought during the first approach.

1- I tried on a PC Duron 1200 MHz and the keyboard worked beautifully with Notepad, Firefox BUT not with Beaver, why ??

2- I tried on two Pentium II 199 and 233 MHz and the keyboard did not work (not French) for none of these two.

I cannot understand why with the same live CD, doing the same procedure, It works on one kind of PC and not with others. That's very strange to me!!! :angry:

Any ideas guys, because actually I need it work on Pentium II, not on less old PCs !!

Thx fot your help  :)
Back to top
Profile PM 
kuky Offline

Group: Members
Posts: 245
Joined: May 2005
Posted: Jan. 06 2008,20:46 QUOTE

try to test these trick (i supoused a hd install and fr latin setup)

ceate frmod with
beaver /home/dsl/frmod

Clear Mod4
add Mod5 = Mode_switch

(save and exit)

put # and add line in /home/dsl/.xinitrc (press H box down Bookmarks to see hiden .files in emelFM) emelFM as super user, right clik on /home/dsl/.xinitrc select view an edit the next lines

# For non-US Keyboards
# if [ ${KEYTABLE:0:2} != "us" ]; then
#  xmodmap -e "clear Mod4" -e "add Mod5 = Mode_switch" &
# fi
  xmodmap /home/dsl/frmod  &

(save and exit)

(ctrl alt and type exit) or reboot dsl i am  not secure of these steep (ctrl alt)

i think that the routine if keytable do not work all the times and with the trick you force to keys in diferent language than US

in spanish its neccesary to add keysim  vocals because the accents are writen in to steeps first the vocal y second a separate  accent..

au revoir mon ami
Back to top
Profile PM 
winux Offline

Group: Members
Posts: 69
Joined: Jan. 2006
Posted: Jan. 06 2008,22:25 QUOTE

Thanks for your nice and comprehensive answer kuky.

Actually in the meantime, I completed the procedure to install a foreign KB. I give here the result. I'm rather happy with it. Much better than release 2.2 two years ago I'd been struggling with. Anyway I'll try your solution to see if it brings any improvement.

Have a nice day kuky, and also all the people of this forum

Here we go:

In order to setup the French keyboard on the current 4.2.2 version DSL live CD , I did the following on 5 different PCs. The result is about the same on the 5 units, I'll list the slight differences just for your information and also maybe for the developers ... Heu Robert you're in the background? :p

A- Setup of the French Keyboard
1-at boot, I typed : dsl lqng=fr (because we startup with qwerty keyboard and on a French KB, a=q)
2- after boot, I checked the KB : Setup > Keyboard and I saw fr  fr
3- I changed it to latin1 : MyDSL > System > xkeycaps.dsl > download
4- I ran
5- I selected
vendor = pc
keyboard = 105 keys
layouts = XFree86;French
5- OK button
6- write output > all keys > OK (I did not do that on my previous post!!)
7- Ctrl + Alt + Back space > startx

B- Results depending on the PCs
1- on one PC (the only Intel one ?!), when I checked the result: Setup > Keyboard
I got fr  fr-latin1
2- on the four others (AMD Duron and Athlon), I still got fr   fr
3- for these four, I had to force latin1 from Setup > Keyboard
4- after Ctrl + Alt + Back space > startx, I was in the same situation as with Intel PC

C- what's right, what's wrong
1- trial with Notepad
everything's fine for 4 PCs:
- accentuated letters such as , , , , : OK
- letters with separate associated sign such as (^+ o), ,: OK
- shift 1st line such as 1, 2, 3, 4: OK
- Alt Gr 1st line such as #, @: OK
the 5th PC, the weakest, Pentium II MMX 200 MHz
- every thing's fine EXCEPT: Alt Gr 1st line meaning NO #, @
2- trial with Beaver
- accentuated letters: NO display, nothing appears on the screen
- letters with separate associated sign: NO good I've got ^o, ^e, ...
- shift 1st line and Alt Gr 1st line: OK
3-trial with Terminal & Firefox (writing in Google search)
every thing's fine EXCEPT letters with separate associated sign
Back to top
Profile PM 
winux Offline

Group: Members
Posts: 69
Joined: Jan. 2006
Posted: Jan. 06 2008,23:11 QUOTE

Hi again kuky

After my previous long "speech", I looked carefully at your reply. A few questions if you do not mind:

1- Is your solution working, as a test, on a live CD version (not installed yet) I think so
2- if I understand correctly
a) I create frmod (/home/dsl/frmod)
b) I write in it:
Clear Mod4
add Mod5 = Mode_switch
c) save
d) in .xinitrc (/home/dsl/.xinitrc)
hide (#): the lines you stated
add: xmodmap /home/dsl/frmod  &
e) save

I think I understood your script, it avoids question: US keyboard yes/no, then you force the scenario non US keyboard, correct?

Should also work on live CD for trial won't it? but better on an installed HD, makes more sense.

Thanks again for your time kuky, hope you have nice weather in Spain, Buenas noches amigo
Back to top
Profile PM 
curaga Offline

Group: Members
Posts: 2163
Joined: Feb. 2007
Posted: Jan. 07 2008,18:24 QUOTE

You can add "loadkeys fr-latin1" to the end of, and you will get latin1 keys automatically on boot (if you have a backup set up, that is).

Seems the default keys for lang=fr should really be changed to fr-latin1..

There's no such thing as life. Those mean little jocks invented it ;)
Windows is not a virus. A virus does something!
Back to top
Profile PM 
16 replies since Jan. 02 2008,01:43 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

Pages: (4) </ 1 [2] 3 4 >/
reply to topic new topic new poll
Quick Reply: French keyboard ... still pending, sorry

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code