Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: XFree86 and Xkb, Another way to use non-us keyboards< Next Oldest | Next Newest >
Whitesparrow Offline

Group: Members
Posts: 6
Joined: Mar. 2006
Posted: Aug. 11 2007,20:14 QUOTE

I was doing a small project with dsl during my summer holydays.
I had to build an X-terminal-solution that works with a lot of different keyboard and screen resolutions.

Because I had no diskspace to waste I decide to use a standart dsl and the Xfree86.dsl.
I did a HD-install and unpackt the XFree86.dsl in the /-directory.

Everthing was working fine, just like i expected dsl to do.
But when I tried a non-us keyboard the first, i noticed that the Alt-gr-key wasn't working.  

I found a working solution in this thread : Look here

Now the german keyboard worked fine, but i needed some other keyboard working too.
And after a lot reading and testing I found out the xmodmap dosen't really solve the problem.
It's more a kind of workaround.
It only 'remaps' the keys after starting the Xserver.

There is still that error message when starting Xfree : XKB: ... fallling back to default keymap.

So I found out that the Xfree86.dsl dosen't include /etc/xkb and the binary /etc/xkb/xkbcomp.
This means you can declare any layout you wish in your XFree86config,
whitout the keymaps and xkbcomp you'll always get the us layout.  

After searching this board I found  a post (somewehre don't remember now) where someone suggest adding the /etc/X11/xkb from a Knoppix live cd.

And this is what I finally did :
I copied the xkb-dir from an old Knoppix 3.2 with cp -rL to my harddrive installation.  
( L becasue I needed the data not the symlinks)
/edit : I've just noticed that you'll also need to create the directory /var/tmp/ because XKB started complaining that he can't write this dir after working fine serveral times.
I started Xfree and there was no more error about XKB and my german keyboard worked as expected with all the Umlaute(äöü) and all the Alt-Gr key.

I don't know wheter someone has mentioned this solution or the reason for this error message before ( I searched the board, but i din't find anything ), so decided to post it here.

I'm also wondering wether the author of that extension hasn't already solved this problem.
I'll try to pack a XFree.dsl with xkb if I have the time to next week

I hope that I was right and no one posted this hint before and that this might help to make dsl more usefull for some people with non-us keyboard out there.


Expert in XFree86,PXE-boot and other illnesses.

~DSL-realted Projects~
+Showcase (info terminals more :
+VM ware XT (an X-terminal running in VM Ware, supporting many keyboard layouts)

Microsoft Windows (TM) may cause crashes or bluescreens.
Back to top
Profile PM WEB 
0 replies since Aug. 11 2007,20:14 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: XFree86 and Xkb

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code