Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: Extreme problems< Next Oldest | Next Newest >
randomtrouble Offline

Group: Members
Posts: 5
Joined: Dec. 2006
Posted: Dec. 02 2006,01:05 QUOTE

I got DSL a week ago or so, and I have gradually become more and more obsessed with it. However, I struggle intensely.

I simply want to run an application called Chibitracker. I'm mostly using the embedded version, running it with Windows XP as the host OS, but I also got the real HD install on an older computer.

(Background info: Before I even thought about compiling, I downloaded an executable file specifically fixed by the author of the program. Somehow, I got the file to execute (but with some errors) that one evening, but never since - I regret I didn't write down all the commands, but this is the core of my annoyance: it HAS worked, so it is obviously -possible-!)

Anyway, I have now gotten to the point where I try to compile Chibitracker myself. It required that I installed Python2.2. In addition to Scons. However, the trouble appear when I am about to activate the installation of Chibitracker. When I type "scons" in the Chibitracker folder, which the instructional document suggests, I get this error:

"sh: line 1: sdl-config: command not found............. Error: cant execute sdl-config, make sure SDL is installed..........TypError: 'str' object is not callable: File 'SConstruct', line 65: exit(255);"

Yes, SDL is installed. I am positive, I have installed libsdl.1.2debian-all mostly. Anyway, I thought maybe I needed something else, something in additition, as the error message questions whether SDL is installed.

So I found out I wanted to try installing "libsdl1.2-dev", and then I got this error:

"Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filled. The following info may help to resolve the situation: The following packages have unmet dependencies: libsdl1.2-dev: Depends: xlibs-dev but it is not going to be installed...... E: Broken package"

Oh - for the record; I also tried installing the "xlibs-dev" package, but it returned the same type of error message.

And regarding my /etc/apt/sources.list file, well, I mostly leave it unedited, but I occasionally edit in as recommended by other DSL/Debian users, but I always have a copy of the original.

Yeah, and as I am asking questions already - is there a way to upgrade the libstdc++5 to for instance libstdc++6? I tried the apt-get upgrade command but it didn't work perfectly.

Now I am curious about your replies.

EDIT: OK - a final question; is there anything you'd recommend me to delete from the standard set with applications in DSL? Something that I may not need. Because it seems like there's only 93.3M capacity in the embedded version. That one decreases fast when working with APT-GET...
Back to top
Profile PM 
0 replies since Dec. 02 2006,01:05 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: Extreme problems

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code