Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: Disable boot messages, Disable boot messages under DSL< Next Oldest | Next Newest >
aptenikhil Offline

Group: Members
Posts: 12
Joined: Dec. 2006
Posted: Dec. 26 2006,05:26 QUOTE

Hi all,
In my project i need to use DSL linux to run some app, But I dont want the boot messages to be shown on the screen. I want only my application to be shown after booting up. I dont want to get any messages on the monitor during the boot process.
On one of the threads in DSL forum i found a way to do it by editing the script under minirt24.gz file. I tried it and was successful in getting rid of the welcome to DSL etc messages by putting all echo commands in comment. But its only 15-20% boot messages, as the rest of the messages are still visible. Is there any way to disable all the boot messages. Please help me regarding this.
Back to top
Profile PM 
fastmonkeywheels Offline

Group: Members
Posts: 5
Joined: Jan. 2007
Posted: Jan. 05 2007,22:32 QUOTE

Well, from what I understand this isn't a help me forum, but rather a place to post tips and tricks.  That said, here's some basic steps to getting rid of the boot messages.

For starters, you'll need a 2.6 kernel, is what I've been using.  I started with DSL-N since is already had a 2.6 kernel.  I followed the instruction at about patching the kernel.  After you have a kernel made with the bootsplash patch you'll have to replace the one you're currently booting with it (or add it for safety reasons on the first couple of boots).  

You need to either make or download a theme, instructions are on, and use their 'splash' utility to add it to the initial ramdisk.  You also need to boot in frambuffer mode, but again all that information is on's website.

I have it working just fine.  I have my post messages turned off, I see a line of text about lilo booting my kernel then BOOM my image is displayed on the screen, the next thing I see is X starting up with my program.  It would take a keen eye to know that linux is running in the background.
Back to top
Profile PM 
1 replies since Dec. 26 2006,05:26 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: Disable boot messages

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code