Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: i can't "Enable APT"< Next Oldest | Next Newest >
wyatt23 Offline

Group: Members
Posts: 2
Joined: May 2005
Posted: May 20 2005,05:26 QUOTE

How's it going.... i just installed DSL. I found an old comp, tried libranet. it was too beefy for my 300 MHZ machine.


i did a hard drive install onto a 6.4 GB hd. everything went fine, DSL boots great. but i tried to "Enable APT" or use Synaptic, and a terminal opens up, does it's business and then closes.

i see that it's downloading "dsl-dpkg.dsl"
it's already made 6 copies of the file.

i really have no idea what to do, but i need my apt.

any suggestions on what to do?

when i enable apt, the screen closes so i cannot see it's error.
Back to top
Profile PM 
WoofyDugfock Offline

Group: Members
Posts: 146
Joined: Sep. 2004
Posted: May 20 2005,07:01 QUOTE

1. Is dsl-dpkg.dsl fully downloading? It should be 1.49MB in size.
If it's zero bytes, then the download is obviously not occuring. Perhaps go to the dsl online repository (see the main dsl page) and download it from there instead.

2. As with all .dsl extensions: to install, select dsl-dpkg.dsl in emelFM and click the MyDsl emelFM button. The desktop will blink mometarily.

3.  Right-click on the desktop, open a shell and type apt-get --help.  You'll see what you have to do there.

4. Or if you don't like the command line, then download synaptic.dsl from the repository if you haven't already.   Synaptic is just a GUI for apt-get.  Install as above.  Click the synaptic icon on the desktop and a panel should open with a long list of Debian packages showing. You'll work it out from there.

NB: If you can only access the internet via a proxy (possibly the case if the 'enable apt' script wasn't downloading the extension), then you need to set the proxy environment variables:

export http_proxy=http://yourproxyipaddress:port
export ftp_proxy=ftp://yourproxyipaddress:port

These can go in any of the system init files but I put mine in ~/.xinitrc.

Or you can just set these variables for apt only in /etc/apt/apt.conf -- see the linux man page for apt.conf(5).

Hope that helps.

"We don't need no stinkin' Windows",39020390,39149796,00.htm
Back to top
Profile PM 
1 replies since May 20 2005,05:26 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: i can't "Enable APT"

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code