Talk:Installing to a USB Flash Drive Beta

From DSL Wiki


READ ME for Discussion Page

This is a discussion page about the wiki content. If you need help with your installation, you'll find it much faster at the forums - it's just that nobody monitors this space answering help-type questions.

All other content definitely seriously welcome. Don't forget to sign your comment if you want kudos (email addy, username, time, whatever works).

Discussion Content

DISCUSSION POST - errors in installation guide

"I am assuming that this is supposed to be a how-to and aimed at those with some to little experence with linux and perhaps NO experence with DSL, If this assumption is incorrect I apoligize. My comments are also based on my experences with the 3.3 release. I do have experence with Redhat and SuSE but have never used DSL before, I have never used a wiki or contributed before either so, If I am being rude or too chatty I also apoligize for that.

I have edited the page to point out the existing tools that work.

I will be working on figuring out the manual process & updating this page as needed. These are now my notes. First, Mention that being root is needed and that there is no root password, you have to sudo sh or sudo bash, (That was a pain to find).

Next, using -- locate mbr.bin -- results in the message  :locate Command not found. However -- find mbr.bin -- DOES work.

Next, Create a FAT16 or FAT32 partition on the pendrive: mkfs.vfat -F 32 /dev/sdX1

Does NOT work as mkfs.vfat does not exist in 3.3,

-- So, having given up on that method for the moment, --- In the section From within Linux using GRUB as boot loader

First you might want to mention the partition type as listed in fdisk or whatever tool you are recommending.

Then the command grub-install --root-directory=. /dev/<device> does not work , it says --no-floppy is an unrecognized option. deleting it then causes grub to probe and fail with a not found or not a block device.

ANSWER start post dentonlt 27 December 2008 07:26 (UTC) I don't know who's posting this was (above), but you had some good comments. I've fixed up the locate vs. find thing to mention both (Install to USB From within Linux).

For the mkfs.vfat thing ... it's not that you need it in DSL - it's that you use this command in other distros. Let me know if I'm mistaken on that one.

Re 'mention the partition type as listed in fdisk' ... this is done (Install to USB From within Linux, Formatting section).

Re grub-install --no-floppy ... actually, that's the version that I used myself (Dec 2008). I've put in a note that grub-install may whine about that argument.

I'm working on putting in your other comments. Next time, just jump in an edit the wiki! Worst case you're wrong, and either you or somebody else fixes it. end post dentonlt 27 December 2008 07:26 (UTC)

DISCUSSION POST - Clarity in Install from Linux

This is a little unclear,

From within Linux
   * Download the dsl-embedded zipfile 

But from within windows, you're just saying DSL, but it is unclear which one ..

Also, on linux, you said to format in FAT16, and in windows in FAT 32 ...


I'm not 100% sure that this was what did the trick, but after having some trouble with this I ran the command

install-mbr /dev/sda

and that seemed to be what fixed it. Can anyone verify wether that would make things work or not?

Also, my system (Ubuntu 6.10) required me to first install the install-mbr command:

install-mbr /dev/sda

-nFriedly 4 December 2006 22:36 (EST)


Hi I would like to know what exactly you mean with booting from within windows. Because this would perfectly match what I am looking for.

- A portable system (linux prefered) - Which I can boot from - and which (in case I cannot boot from) can be started in windows as well as in Linux

So here is my question can I boot from any of these systems ? +++++++++++++++++++++++++++++++++++++++++++++++++++

You can boot a PC from what is called a LIVE CD. It is designed to let you boot into Linux without installing it on your hard drive or damaging anything in your current system. Your computer must be able to boot from a CD to do it though.

To "boot inside windows", you need a virtual machine. Look at under the topic virtual machine to run linux inside windows. It's pretty cool. With it you can "boot up" a Linux Live CD ISO that is on your hard drive from within windows. It is at: The software is called VirtualBox.

I was even able to run Gparted inside the Linux virtual machine to modify some partitions on a USB drive not being used by Windows or Linux at the time.

There are many Live CD's available on the internet. You need the ISO file, which is usually about 600 or 700MB, the size of a CD. You can burn the ISO to a CD to boot from the CD if you don't want to run it inside windoze. A bunch of them are linked here:


It would be nice to have a "From within Mac OS X" section.

Start post dentonlt 27 December 2008 07:31 (UTC) I've added a mostly blank page on installing from Mac OS X. I don't have a Mac, or I'd figure it out myself. Explore and add your experience to the wiki! end post dentonlt 27 December 2008 07:31 (UTC)

DISCUSSION POST: Installing from within Windows (unclear)

I feel that this section is very unclear. When told to "run syslinux for the drive," I don't really understand what to do. I think somebody should really clarify this section.

Agreed, this is quite unclear. Please someone help?

Agreed again by me.

Maybe we have to install the syslinux we just downloaded?

Some explanation needs to be made where syslinux needs to be extracted to. There a lots of ifles in the syslinux folder. I extracted syslinux folder and all its contents to the usb drive which happened to be F: and then ran the SYSLINUX -ma F: command which created a .sys file. However when I rebooted I got 'unassigned' error messages ???

Help about using syslinux

Hello people,I am a windows user and this DSL seemed to be the perfect choice for myself.But I can't find out how I run syslinux.I have used cmd to move to the folder containing syslinux.exe,and when I run syslinux -ma F:\ it says:

Usage:syslinux.exe [-sfmar][-d directory](drive): bootsecfile

Anyway,I think somebody here can help me.I will appreciate any help.

Update:I finally got DSL to work.Thank you for creating this awesome OS,it's awesome.

REPLY TO THE ABOVE: Umm, the point is to HELP PEOPLE. Don't post an issue and say, 'Oh, I fixed it, bye' - HOW DID YOU FIX IT, GEEZ... At least have the courtesy to delete you previous comments if your going to keep it to yourself...

I had the same problem, but got rid of the error by typing just the drive letter and a colon, e.g "syslinux.exe -ma F:" (without the backslash). -- 7 November 2008 15:53 (UTC)

Compilation/Cleanup Project

Since this is quite a long page, with lots of Discussion content ... I'll embark on a journey to clean it up. Dunno when I'll finish, but help certainly welcome. Predicted process (don't hold me to this):

  • Add Intro & TOC statement
  • Standardize process/steps for the installation types
  • Move odd cases to separate section at the end

dentonlt 26 December 2008 09:30 (UTC)

USB Install - Beta Page

Since there are lots of ways of installing to USB, this page is damn long. I've made a beta page to experiment with breaking up the content. dentonlt 26 December 2008 11:36 (UTC)

Where the ... ?

  • I have no idea where to put the VNC Modifications content ... but it doesn't look like it belongs here. Open to suggestions.

dentonlt 27 December 2008 03:18 (UTC)

Beta page up

  • Seeing no complaints (as that went faster than I thought it would ...), I'm posting the beta as the new main page. Apologies to WinterKnight if that's a bit bigger change than normally desired. If it's a problem, the old page is still online at Installing to a USB Flash Drive Old.

dentonlt 27 December 2008 07:35 (UTC)