Damn Small Linux (DSL) Forums

MyDSL Extensions => Extension Development => Topic started by: carlo on October 08, 2014, 07:55:19 AM

Title: recording sound
Post by: carlo on October 08, 2014, 07:55:19 AM

I have the latest stable dsl installed with oss sound.
When I'm using soundtracker and, I want to record something with the build-in recorder, it doesn't work.
So then I open audacity to do it. I've noticed that from that moment on (when audacity is working and, I have been recording something) recording with soundtracker also works.
That means that audacity installs something (maybe a module, a driver, or library) that enables the entire system to record.
Does anyone have a clou what that might be, so I can enable/install it by default.


Title: Re: recording sound
Post by: CNK on October 08, 2014, 11:10:42 PM
Check in Dmix (DSL menu > Apps > Sound) that the Audio Input isn't muted, if you haven't already.

Otherwise you can list what modules are loaded in the terminal with the command "lsmod". You can compare the lists with and without audacity running and Google any modules that it loads to seeif they might be relevant.

Title: Re: recording sound
Post by: carlo on October 09, 2014, 02:37:24 PM
Thanks for the advice

It's solved.
In Audacity I enabled the "input gain" line to record.
So, when I open Dmix and, in the upper left corner I choose "input gain" to push the "rec" button there; it works


Powered by SMF 1.1.20 | SMF © 2013, Simple Machines