Damn Small Linux (DSL) Forums

Damn Small Linux => USB booting => Topic started by: Nathuksouth on September 14, 2015, 05:38:30 PM

Title: Cannot Access Internet
Post by: Nathuksouth on September 14, 2015, 05:38:30 PM

I'm new to linux so i'd be grateful if you can bear with me. I have been trying to run DSL from a flash drive but i cannot access the net. i have broadband so i don't know why this is not connecting.

Can anyone please shed light on what could be the problem?


Title: Re: Cannot Access Internet
Post by: CNK on September 15, 2015, 10:34:03 PM
Are you connected using WiFi or ethernet cable?

If Ethernet, try the netcardconf program in the DSL menu under "Setup > Net Setup". Presumably DHCP is enabled on your router or modem, enable this option in the settings to have it configured automatically.

If it doesn't work, open a terminal window and use the "ifconfig" command to list your network interfaces. Normally there will be two listed on the left, one named "eth0" and another "lo". If your computer also has a wireless interface, that may be listed too. Try any interfaces listed additionally to these two in case one is your ethernet connection.

If you want to connect with WiFi, you should use the iwconfig menu in "Net Setup" to configure it. Again, you'll need to know the interface name if it isn't "eth0". Use the "iwconfig" command in the terminal to list any detected wireless interfaces. If no wireless interfaces are found (the only results say "no wireless extensions"), then you'll need to look into the chipset used by your wireless interface and check which Linux drivers should be installed or configured to make the interface work.

Your networking hardware should be listed as a device in the "pci" section of the "system stats" tool in the DSL Menu under "System >", unless it is a usb device in which case using lsusb at the terminal might reveal it. The information listed here may be useful for identifying the chipset used by your hardware if it has not been correctly detected by DSL.

Title: Re: Cannot Access Internet
Post by: jharris1993 on December 31, 2015, 02:14:35 AM

And yes, I know that this thread is a bit stale. . .  However, having run into the same issue recently using several different versions of DSL, I thought I'd toss in my two centavos.

Edit the boot command-line to remove the word "quiet", since "quiet" causes all the very interesting - and informative! - boot messages to be hidden.  In cases like this where hardware may - or may not - be misbehaving, it is absolutely crucial to know what the system thinks about it at boot-time.

If you have, (for example), a 3-Com 3C589D PCMCIA card in a laptop slot on your system, and you get messages like "unrecognized PCMCIA device '3-Com 3C589D' " - then you know that messing around with the "net setup" won't get you far since this is telling you that the system has no clue what your network card is.

On the other hand, if you get messages that indicate that the system found the card, recognized it as a network card, successfully activated it, and attempted to get it working by "backgrounding" something like DHCP. . . .  if your network still doesn't work, then the net-setup page may well be your answer.

Important take-away:  Especially in Linux, and double-especially in micro-Linuxes like DSL, Boot Messages Are Your Friend!

In my case, the card would get recognized and activated, but I'd have no network connection, so I had to go to the Net Setup section and give it a boot up the arse with a #9 steel-tipped boot  ;)  by making sure that within Net Setup the network was set to "DHCP" and not "Manual" (or "static")  This is supposed to happen automagically, but often times it does not.

If your card, (or WiFi, or whatever), is NOT recognized at boot time, you will need to spend some time on the Web researching it.  Searching for whatever the text of the error message is, is often very helpful.

Hopefully this tiny addition will help someone else out there in Television Land who is banging their head against The Network Dragon.  (And now you know why Network Admin's get the Big Bucks!)

What say ye?

Jim (JR)

Title: Re: Cannot Access Internet
Post by: Hankbonk on June 18, 2017, 09:12:18 AM

I have the same problem : DSL doesn't get an internet connection . I tried the netcardconf program in the DSL menu under "Setup > Net Setup" and tried to change they DHCP to on then I clicked "Apply", but it did not change that setting ...

And how do I know the name of my ethernet card ?

Please advise .

Title: Re: Cannot Access Internet
Post by: CNK on June 19, 2017, 10:21:13 PM
Looking at the results of the "ifconfig" command in a terminal, as I mentioned above, is the way to identify names of the network interfaces detected on your computer.

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines