Damn Small Linux (DSL) Forums

MyDSL Extensions => Multimedia => Topic started by: AB77 on May 02, 2016, 08:15:47 AM



Title: Can't watch .mp4 videos
Post by: AB77 on May 02, 2016, 08:15:47 AM
I've installed mplayer.dsl and xine.dsl and neither of them can play .mp4 videos (but play only its sounds).
mplayer says "Cannot find codec matching selected -vo and video format 0x31637661"
xine says "The stream '(file pass and name).mp4' use an unsupported codec: Video Codec : Unavailable (avc1)"

Why the hell can't they play mp4 which is very common format?
and how can I fix this issue? or is there any apps can handle mp4?
Hope somebody reply.


Title: Re: Can't watch .mp4 videos
Post by: CNK on May 02, 2016, 10:56:30 PM
.MP4 files can actually contain video and audio in various different formats. It would appear that the video you're attempting to play when mplayer shows that error message is encoded in the h264 format (a version of MPEG4 video, which the MP4 container format was designed to be used with).

h264 video is now a very common (possibly the most common) video format, but the mplayer extension was made in 2004 when Xvid was a more common video codec.

In any case, mplayer may work if you load the mm-base.uci extension in Testing section of the myDSL respository before running mplayer. This contains numerous codecs, including h264.

That extension is not mentioned in the information for the mplayer.dsl extension, so you may have to use the later mplayer.tar.gz in the Testing section of the respository if you still get the same error message after loading mm-base.uci.

I personally use VLC, which is also presented as an extension in the testing section as vlc.uci. it requires gtk2-core.unc and libwxgtk2.uci to be installed as well as mm-base.uci.


Title: Re: Can't watch .mp4 videos
Post by: AB77 on May 03, 2016, 07:18:24 AM
Hi, CNK. Thanks for your reply.

First, it seems I was misunderstanding what format is. thanks for telling me that.
And saddly all your suggested way doesn't work in my old PC. but I would appreciate your help.
As a result, I found the xine.uci in testiong area is working! hope xine behaves well for now.

my PC data : AMD Duron processor, CPU 1300MHz, age 14


Title: Re: Can't watch .mp4 videos
Post by: CNK on May 03, 2016, 10:44:44 PM
Strange that loading mm-base.uci didn't help. Did you try VLC?

Are you running DSL from the CD, or do you have it installed? If it's installed, is it a frugal or HDD install? If it is a HDD install, it's possible that your installation of mplayer.tar.gz was confused by the files installed previously by mplayer.dsl. A similar problem could exist with a frugal install, or running from the CD, if you didn't reboot between trying mplayer.dsl and mplayer.tar.gz.

If you're using a HDD install, try starting mplayer with the command "/opt/bin/mplayer <arguments>". That may use the new version whereas simply typing "mplayer <arguments>" would still use the old one. You could check the version information to be sure.


Title: Re: Can't watch .mp4 videos
Post by: Somponggun on January 05, 2017, 09:30:23 AM

I have read all of the content people. I feel it is very good.


Powered by SMF 1.1.20 | SMF © 2013, Simple Machines