Damn Small Linux (DSL) Forums

Damn Small Linux => Other Help Topics => Topic started by: Kewun on September 01, 2016, 10:04:05 AM



Title: libstdc++.6.so
Post by: Kewun on September 01, 2016, 10:04:05 AM
In Damn Small Linux, im getting a error for libraries libstdc++6.so I
 dont have the libraries, And can't enable apt-get because of 404 error download
. i cant download the libraries I wanted to start a game server on the linux, but this error occurs.

Any alrternative to enable apt-get ?

btw i installed dsl  in virtual box


Title: Re: libstdc++.6.so
Post by: CNK on September 01, 2016, 10:43:54 PM
DSL comes with libstdc++5. You may be able to get this package (https://archive.debian.net/sarge/libstdc++6-dev) to install, even though it is for a later version of Debian than the one DSL is based on, by manually installing other dependencies.

It may be easier to compile libstdc++6, which part of the GCC compiler (http://gcc.gnu.org/gcc-6/), from the source code.

Remember to also check the other dependencies that the program you are trying to run requires. It is possible that it may require a later Linux kernel than the 2.4.31 version used by DSL, and this will make it incompatible. If so, you may want to check past versions of the program before moving on to other alternatives.

EDIT: Sorry, as for apt-get (even though it won't help you anyway, because there are no libstdc++6 packages for Debian Woody), you can download the dsl-dpkg.dsl MyDSL extension to enable it from the "System" section of the MyDSL respository (http://distro.ibiblio.org/damnsmall/mydsl/).


Powered by SMF 1.1.20 | SMF © 2013, Simple Machines