Damn Small Linux (DSL) Forums

Damn Small Linux => Laptops => Topic started by: carlo on April 01, 2017, 09:07:24 AM

Title: no sound card and no drives
Post by: carlo on April 01, 2017, 09:07:24 AM

I want to install dsl on an notebook HP G7000.
When I boot the cd I see that the sound card is not detected but, when I do
later on, I can see that the card is ‘intel corporation 82801H’. When I put on the alsa boot option and load alsa4dsl and try
depmod -a
etc... than
returns almost everything with ‘unknown device’. (I think it does’nt recognize it anymore) and when I load the driver ‘snd-intel8x0‘ it returns ‘no such device’

With Puppy I have wiped out windows vista and created new partitions. These partitions niether those from Windows (before) are detected with dsl.

Will this change when I make an image of a partition with dsl installed on it and, copy it in a partition?
Or before formatting the hard disk (it has only one) in ext 2 will it help if I make the device msdos (or one of those possibilities) with Puppy 528. Maybe the original msdos (which held ms vista) is to modern.

Or is there something else I can do to make it clean install?

Title: Re: no sound card and no drives
Post by: CNK on April 01, 2017, 11:46:53 PM
I'm not sure why the PCI device list is getting confused, but have you tried running the ALSA configuration script at "/opt/alsa/alsasetup"?

As for the problem with reading partitions, the specs pages I've found online don't say what type of Hard Disk the G7000 has. If the Hard Disk is SATA, you'll have to use the "sata" boot option with DSL. Failing that, I would recommend rewriting the partition table as "msdos", then creating your partitons again. I usually do this with the program "parted" using the command "mklabel msdos", but any partitioning program should do.

Title: Re: no sound card and no drives
Post by: carlo on April 05, 2017, 12:55:54 PM
Hello again

I already have the drive visible after disabeling Sata in the Bios. Thanks for the Sata hint.

Still no sound!
Alsasetup sais “no pnp or PCI card found and, the legacy drivers don’t work neither.
When I start Puppy,... there is sound so, normally it is working. I can see that Puppy’s driver is snd-ens1371, and snd-ac97-codec. When I try to load them with “insmod snd....." I get lines like “unresolved symbol gameport_reg......” for the first one. The second one loads normal but, still no sound.
At dsl bootup (I have it installed now) I get a line “modprobe can’t locate module-block-2“.

Title: Re: no sound card and no drives
Post by: CNK on April 05, 2017, 10:45:21 PM
I don't think I've had to set up ALSA manually before, but these instructions (http://www.alsa-project.org/main/index.php/Matrix:Module-ens1371#Setting_up_modprobe_and_kmod_support) describe manually configuring the drivers. It seems that simply using insmod isn't enough. /etc/modules.conf will probably already contain some lines generated by the ALSA autoconfigure program which you should replace.

If that boot error is "block-major-2", that always appears when you don't have a floppy drive in your system.

Title: Re: no sound card and no drives
Post by: carlo on April 25, 2017, 01:13:34 PM
I was wrong it's "snd-hda-intel" that i should load (the previous I found among others, after doing lsmod ,lspci gives this one) and, I can see now that the kernel driver "HDA Intel" should also be loaded first in order to recognise the card. So doing "update modules" or adding the modules in the file as mentioned in the link page wont help (card still not detected).
As far as I can see for this kernel driver I need at least kernel 2.6.22. Anyway I'll try it later , maybe it will work. But I have bad expirience with upgrading a kernel.

To have my Wifi up and running I have a simular problem. I allready tryed to load it (kernel driver) but, after loading "gcc with libs" and doing the "make" command it says "cc: command not found". So this means that "make" is there but, someting else is wrong. Maybe I have to retry.
So I continu searching with the time I have.


Title: Re: no sound card and no drives
Post by: CNK on April 25, 2017, 10:27:35 PM
That error means that the "cc" command, which should call the compiler, isn't being recognised. Did you run ./configure first? That might change the command used to "gcc" which is more usual. If it still insists on using the "cc" command, you could make a symlink called "cc" in /usr/bin, linking to gcc.

Title: Re: no sound card and no drives
Post by: carlo on May 17, 2017, 12:59:27 PM
Thanks for the cc hint. Now I was able to install but, nothing changed. iwconfig still gave "no wireless ..."
The driver was "madwifi", (you can download it here "http://snapshots.madwifi-project.org/madwifi-hal-"), I can see now Puppy uses the "ath5k" one. It's probably one for a later kernel.

For the sound I had downloaded the realtec alsa driver. "Installing" worked fine but after it, I saw that there were no modules in the modules directory.
If installed withouth preïnstalling the alsa4dsl extention, many modules are present but not the "snd-hda-intel" one. Aldaugh it is in the packet.

For the moment I will be away for a while (few months). So if someone has a solution he may always write.
I dont know how long a treath can stay open.


Title: Re: no sound card and no drives
Post by: CNK on May 20, 2017, 12:43:40 AM
Here are the modules loaded on the PC I'm on in order to use the PCI WiFi card which uses an atheros chipset:
ath_pci                67484   1
ath_rate_sample         9736   0 [ath_pci]
wlan                  138904   1 [wlan_scan_sta ath_pci ath_rate_sample]
ath_hal               174608   1 [ath_pci ath_rate_sample]

The module files themselves are in "/lib/modules/2.4.31/net", and I believe they are part of the DSL 4.4.x installation. They load automatically for me.

The model of chipset is reported by lspci as:
Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

Perhaps that will be of some help if you need to load modules manually using modprobe. I don't know enough about alsa to be much help with the sound issue unfortunately.

Also, the WiFi card is identified as "ath0" instead of "wifi0" (which is left marked as "no wireless extensions.").

Title: Re: no sound card and no drives
Post by: carlo on July 24, 2017, 09:44:05 AM
Hello I'm back

I'm affraid I have bad news.
I can't have wireless nor sound anymore on my laptop with dsl.
You where right, the atheros driver is installed and configured at boot time. Here is the output of lsmod |grep ath:
ath_pci                67484   0 (unused)
ath_rate_sample         9736   0 [ath_pci]
wlan                  138936   0 [ath_pci ath_rate_sample]
ath_hal               174608   0 [ath_pci ath_rate_sample]
What "unused" means, I don't know but, when I laod it manualy nothing changes.
My card is a bit different from yours. It just needs that driver for kernel 2.6 I guess.
For the sound card it's the same.

I have been searching for a decent OS with emelfm, xmms, and all those load possibilitys for extensions like dsl. But I can't find it.


Title: Re: no sound card and no drives
Post by: CNK on July 26, 2017, 10:47:18 PM
The unused bit indicates that the driver isn't setting up the card, so unless something in the configuration has been messed up it looks like your chipset isn't compatible with the atheros (Madwifi) driver in DSL.

You could try DSL-N, which uses a 2.6 kernel. The software is a little less up to date than in the main DSL though. AntiX Linux is similar in some ways to DSL, you might be able to install emelfm2 in it using the package manager.

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines